Debug.log is absent

Hello everyone,
I have chia installed on PopOS.
While doing some troubleshooting I deleted the debug.log on ~/.chia/mainnet/log thinking that it will be recreated.
Now, farming is working without any issue but I can no more check debug.log as it is absent.
I tried re-installing debian binary , installing from sources but still no debug.log is being created.
Please help me fix this issue
Thank you.

I can only advise trying to uninstall then reinstall, or manually creating the folder yourself, if those fail possibly start afresh installing the os.
Have you disabled logging possibly in .yaml?


There is another possibility that Chia changed location of that log (or mainnet) folder. Maybe you could sudo find / -name debug.log to check for a new location.

One more possibility is that when you deleted it, the parent folder has privileges that prevent chia from creating that folder / debug.log.

That log should be created (if not there) every time chia starts, so reinstalling chia doesn’t really make much sense.


Thank you @Jacek ,
It was the folder permission issue , for some reason the folder “log” had only read permission (still scratching my head who did changed the folder permission)
Once I assign the write permission to group and users the debug.log came automatically without having to restart chia application (service).
Thank you again for the helpful insight.


Happy that you got it working!

1 Like