Error Connection closed after create new wallet


I install fresh win 10 Pro and new Chia version 2.1.13. Started chia normally, I select Farming version, not wallet, and after that I choose NEW WALLET. Confirming a new wallet and after that I got message Error, Connection Closed and then Connecting to daemon. I could not find anywhere same topic.

If this is all new install, did chia sync up?

Before you tried to make a wallet??

I’m having the same problem. Running 1.8.2 since it came out, w/no problems. Every 2.x version I tried upgrading to had the same problem, wouldn’t load keyring. No time to solve Chia problems, figured next version would fix whatever the issue was. Would reinstall 1.8.2 and run fine. Today decided to bite the bullet and upgrade to 2.1.3. Same problem and did some research. I have no keyring.lck file so decided to just delete the keyring file that’s there. That get’s me past loading keyring. Now I have to import my wallet using the key words. That’s where I get this new problem, Error, No Connection. Reinstall 1.8.2 and running fine, synced, etc. How to get past this to 2.x?

Do you have the v2 database?

If you mean the version that compressed, or shrunk the DB from over a year ago, yes.

What you might try is shut down chia. Go to you user root level and rename .chia to .chia-cya rename .chia_keys to .chia_keys-cya

Run the chia GUI and retype in the 24 key words and see if this new version starts syncing. Don’t know how fast you download is, if you didn’t want to wait to sync on your own you could download the database from

But will still have to wait to sync from Oct 1st. Also you have to modify your config.yaml to add disk plot folders etc.

I get this error if i put 24 words from recovery wallet or if I create a new one. First I was thought that this is because of the windows system, so I install fresh version of Windows and new wersion of Chia, but same problem persist. So I think something is missing in chia maybe or in windows. Anyone knows what the problem could be?

If you installed a fresh copy of Windows, I would also install these packages
Lets me know if this helps.

I install VisualStudioSetup.exe and VC_redist.64.exe and getting same error. Then I uninstall Chia version 2.1.3 and instal version 1.8.2 and it is working normally without any errors. So I’m sure that there is still something missing in fresh instalation of windows 10 and newer versions than 2.0.0 of Chiat are not working. Any suggestion what is missing?


Can I ask how much space you have on your C:\ where Chia and the database would be installed?
And have windows updates etc.

On C: I have more a little more than 400 GB free of space. I think that if there would be a problem about the space, also version 1.8.2 of Chia will not work. Am I wrong?

I had to ask, some folks trying to use a 100gb disk. Do you get any messages in the log file? ‪C:\Users\root.chia\mainnet\log\debug.log

I manage ver. 1.6.2 and 1.8.2 of Chia to be working. Also when I start the Chia and selec import 24 word, it imported it ok. After import also start sync without any problems. But now I have another problem. My db backup is version V1 and the new db is V2. Even if i copy my backup db into this folder of Chia db, syncing start from 0, not from the possition when backup was made. Any suggestion?


Its been a long time since I played with v1 DB. Since you are so far behind you could download the DB from
Downloads - Chia Network
and still have to mess with copying the right spot etc. If it was me and you spent all this time with this , Keep a backup of your old config.yaml and rename the copy to condig-182.yaml for safe keeping so you can get things from it if needed.I would delete the db folder and install 2.1.3 and start chia and let it sync for a couple of days and you know its your stuff in there.

1 Like