Farmer not syncing. Add peers via CLI?

When I do chia show -c I see a bunch of nodes (FULL_NODE).

However, when I check the summary, I see
Farming status: Not synced or not connected to peers

How do I get it connected/synchronized? Port 8444 is forwarded. When I’ve searched for an answer, I found some posts that talk about adding a peer but they don’t mention how to do that with the CLI (only GUI).

My best guess is that I would use chia configure --set-farmer-peer. I tried that with I’m not sure if that’s right.

How do I get the farmer to start syncing?

1 Like

I’m not very good at the command line, but would the introducers be of help?

  • North Asia
  • South Asia
  • Western North America:
  • Eastern North America
  • Europe:

You can get the latest introducer list via keybase chat, there’s a ! command to list them. Not sure how often they change; the above is from a 9 day old reply on a github issue.

1 Like

I tryed to connect to but failed.Then I tried North Asia,South Asia,etc and also failed.
Connecting to, 8444
Failed to connect to

You can’t add peers from the cli.

You need to use the UI or make a call to the RPC interface.

For example, to connect to you can do:

curl --insecure --cert ~/.chia/mainnet/config/ssl/wallet/private_wallet.crt --key ~/.chia/mainnet/config/ssl/wallet/private_wallet.key -d '{"host":"","port":8444}' -H "Content-Type: application/json" -X POST https://localhost:9256/open_connection

You’ll get {"success": true} if it works.

Wow, you’ve gone and dug up a pretty old thread here buddy.

For the record, you can connect to an introducer with

chia show -a

It will then show in your peer list under chia show -c

1 Like

Google dug it up, I was just adding to it. :slight_smile:

Nice to know it’s been added to the cli though, that saves a lot of messing around.

1 Like