Gigahorse GPU Plotter, GPU Farmer, Plot Sink: Boost Your Chia Farm by 47.2%! Plot in <2 Minutes

so basically 8-10 mins?

For farming yes, for plotting no. There is very little bandwidth needed for farming/harvesting.

C7 74.6GiB x 1.024 x 1.024 = 78.22 Gb average speed on sata will be around 200Mb/s (depends of lot of things from 40-200 in my case)let’s take 200Mb/s
78.22 x1024 =80097.28 MB / 200Mb/s = around 400 sec for one plot for saving 6.67 min 200Mb/s x 8 that is 1.600Gbit/s if your plotting time is faster than 6.67 min than all the proces should be more faster too!I my case my plotting time is around 84 sec and I use for transfer plots over network a 10GBit network cards and data transfer is around 6-7Gbit/sec
So 1GBit is to slow for transferring plots over network!
For farming should be ok

I won’t be transferring the plots. I will only be using network shares.

Usually VRAM is not enough to do both at the same time. Need 12 or 16G VRAM.

My GPUs are 2xA4000 with 16GB VRAM each.
So farming doesn’t utilize GPU’s core and it doesn’t impair plotting performance?

Hi, I’m Lieutenant Dan on Discord and I’ve been optimizing my tests to such an extent that I achieve 173 seconds per K32-C8 plot.

RTX 3060Ti
128GB RAM 3600mhz CL18
3x1TB RAID0 Z440

I think that within the 128gb category I have the best time recorded. Maybe…


Impressive, except, if you get 2 of your setup it will be twice as fast.
Surely the best measure is kWh per plot?

I’d like to try one of those z440 tho

Nice result!Good idea is the third nvme :-)Myabe i will add one more 1TB Nvme to my 128Gb setup

Plotting will slow down a bit, but otherwise will be ok.

1 Like

Are all 16 PCI lanes required for just farming? Or if I run out of VRAM on a single GPU and I only have a spare x1 slot, can I just hook up a GPU in a X1-X16 riser?

The truth is that I do not have an accuracy of kW/h on the plot, what I can assure you are the times. I uploaded an image of everything with said config so they don’t think I’m “inventing something unreal”. Full system stable while plotting and copying to HDDs is at the end of 186 seconds per plot K32-C8.

Important for me, not stay with the standard values of the BIOS.

x8 PCIe 3.0 is still fine, but less than that not, especially not x1. Also VRAM is not shared, every GPU needs their own.

1 Like

I’m trying to switch to Gigahorse, but I’m having some issues.

Farming on Windows 10 Pro 48GB of memory, and 3060 12GB GPU
Plotting on Windows 10 Pro 512GB with 3080 GPU

When running chia plots check from the Gigahorse folder on my farmer, when it completes the checks it doesn’t return to the cmd line, any idea what’s causing this? Apart from closing the window there doesn’t appear to be anything I can do, ctrl-c doesn’t do anything.

Second problem is most the plots fail with the following error.

ERROR <class ‘MemoryError’>: bad allocation error in getting challenge qualities for plot

Any idea what’s causing this please?

Where does Gigahorse farmer report bad plots?

Also whilst I’m here spotted this in the log file (predates my use of Gigahorse), but Google doesn’t return anything, any ideas?

WARNING PUT /farmer response: {‘error_code’: 8, ‘error_message’: ‘You are requesting too many updates of your payout address! Please ensure all farmers have the same payout address configured!’}

128GB RAM DDR4 3600MHZ CL18
173 Seconds - Plot K32 - C8


Seems like an issue with your hardware / driver, are other applications using the GPU working fine?

@madMAx43v3r thanks for the reply, its in a headless server, no other applications are using it as far as I’m aware.

I’m using the Studio driver 531.61.

The server does have onboard graphics, but the only one that shows in task manager is the 3060, and when I run plots check it spikes to about 4% usage.

Would the farmer be logging any errors or bad plots?
How can I test the GPU, apart from hooking up a monitor?

4% usage sounds like it’s not using the GPU but CPU. You can run some CUDA benchmark to test it.

I’ve just run the Cuda CompuBench - performance benchmark for various compute APIs (OpenCL, RenderScript) and it ran without issue, results seem in line with NVIDIA GeForce RTX 3060 performance in CompuBench - performance benchmark for various compute APIs (OpenCL, RenderScript)

Also ran the plot check on the plotting workstation, all plots are valid except for one duplicate, so it is something related to the farming server. But the plots check didn’t exit cleanly, it still didn’t return to the cmd prompt.

Noticed the plotter has a slightly earlier driver version, will try that.