GPU Plotting on Dell Workstation running Windows 11

Just start to experiment with GPU plotting so not really sure about any of this. Initially I had an NVIDIA P2200 graphics card and 512GB of CPU RAM in my Dell Precision Workstation. Using the Chia GUI I was able to create a C1 compressed CUDA plot. However it did take 40 minutes. The GPU was being used during the plot but maybe the problem here is that this graphics card only has 5GB RAM.

Next test. Now got an NVIDIA T1000 8GB. Finally got to understand the CLI format for a Bladebit_cuda plot command, but it reports that the CUDA version is not high enough. Also in the Chia GUI the CUDA option is not available.

The computer runs Windows 11.
Has anybody had any experience with updating the CUDA driver for the T1000 8GB card?

I have found this file on the NVIDIA website:

If I run it, I just get the Windows busy circle going round and round.
I will try again in a day or so.
Any help in the meantime much appreciated.

Check the Nvidia site for your specific card.
Usual “consumer” driver versions often DO NOT support workstation cards like yours.

Dell had come up with various critical updates required. One was the BIOS and another was an NVIDIA update which turned out not to be compatible with the 8GB version of the T1000.
The file from NVIDIA that I specified in the original post was indeed the solution. I ran a C1 Bladebit cuda plot and it took 16 minutes. I think that included the copy time as well which it seemed to be doing as the plot generation was progressing.
I am only investigating this just in case any future hard fork requires me to replot about 3500 K34 uncompressed plots.

Honestly FY ledger. We were begging years and now Passkeys and better ways are just around the corners. It should be Ledgers responsibility to get relevant Chains supported - and yes chia is by many metrics a very relevant chain. If I remember correct Bram and Chia even had real headache to get the whole BLS thingy changed to fit with Ledgers requirements. Let them rot at this point.

I helped a friend acquire a substantial amount of chia and if ledger would be an option I would p[robably have recommended and set it up with him. Totally insane what Ledger is doing as a company - the latest problems with just pulling 3rd party code (supply chain infection) don’t look good either. Ledgers are like voting machines. Once u look under the hood they start smelling.

Good morning, I have a Dell Precision Workstation T5810 with 256gb and a Nvidia 3060-12gb and 4 nvme raided for the temp drive, running windows 10 or 11 and make Gigahorse Cuda plots in 2.8 minutes with no problem.

That graphics card is a bit more powerful than mine and looks like it takes up 2 slots. A luxury I don’t have. I assume that if you are filling up your temp drive at 1 plot every 2.8 minutes, you have another mechanism that’s copying these plots to a normal SATA/SAS hard drive for farming. So if you run your plotter continuously for 24 hours, how many plots have you actually created that have been copied to their final destination?

I have this filled currently with 4 Samsung 970 EVO 1 TB as my temp drive, I raided them in disk manager as a single drive.
Here is my string that works for me set the plot count and walk away.
cuda_plot_k32_v3-2 -n 1 -x 8444 -M 128 -C 30 -t g:\nvme\ -d h:\C30\ -f fffff -c ccccc

1 Like

What model number Dell do you have??

1 Like

You don’t need the -x 8444 argument, as that is the default mode.

1 Like

Its whats saved in my text file, lets me know that I’m making a Gigahorse Chia plot. :joy:


Dell Precision Workstation XEON-5820
Processor Intel(R) Xeon(R) W-2245 CPU @ 3.90GHz 3.91 GHz
Installed RAM 512 GB (512 GB usable)

Powershell command line:
.\bladebit_cuda -n 1 -z 1 -c ccccc -f fffff cudaplot \Synology-1821\chiaplot0\

I assume that my temp directory is automatically the main computer RAM.

1 Like

There are 2 back slashes in front of Synology.

1 Like

is this your motherboard?

Looks about right, with an 8 core xeon processor and 512 GB RAM. 2TB SSD for the OS. 1TB SSD used in conjunction with the CPU RAM when I do standard (non GPU) MadMax plotting.

You have 5 pcie slots you only need two.

They are all filled up with other cards.
1 10GB network card
1 PCI to USB
1 Thunderbolt card

I will do some more tests in a day or so to see what happens if I set the plot count to say 4.
Then we all have to wait and see what options we have to replot as we go through various stages of the hard fork.

You have 6 USB 3.0 ports on the motherboard. You have 8 sata ports on the motherboard. Do you have a 10GB network running? What is connected to the Thunderbolt card? If your going to make a plotting machine, you have the beginning items, you just need to think what you need connected. What type of Sata card is it, hope its not just PCI?
This seems like a nice machine

I use this cable I got it for $20 last year. Nothing particular about this brand.

My local network is 10GB.
This computer is not just a dedicated plotter. It plots, farms all at the same time. One of my NAS’s monitors a bunch of surveillance cameras. So there’s quite a lot going on.

This is what I bought from Amazon. It probably needs reflashing to sort out some SATA issue, but it does work in the Chia environment providing you fill up the drives with plots prior to connecting to this card. That’s my experience anyway.

LSI 9300-8i RAID Controller Card PCI E 3.0 12Gbps HBA IT mode ZFS FreeNAS unRAID RAID Expander + 2 SFF-8643 SATA Cable.

I will investigate using those onboard SATA connectors.
If that works for all 8 ports, I could remove the above card.
But I am going to do more tests using the Bladebit plotter. At the moment it is pointless for me to replot anything. I shall wait and see what the new requirements are as we approach the hard fork.

1 Like