I run chia on macOS, but it always show"Connecting to wallet"

I didn’t close the chia app normally, so maybe the file contains wallet data was incorrect.
what should I do? last time, I recovered my pc… but this situation happens again.
I wanna uninstall the chia app. but it didn’t work. because I can’t find the wallet data file.

Wallet DB is in this file location. C:\Users\Your_User_Name.chia\mainnet\wallet\db

Oops just re-read your using MacOS, not sure if it is the same location.

1 Like

yes, thanks bro. windows dir is easy to find.
But Mac is not the same…

It’s in a hidden folder on Mac. I’ll link a video that shows how to bring them up, the video is showing to delete everything, but I think you should be able to just find the wallet db and delete it.


I’ve tried the way in the video. but it seems can’t find the “.chia” in macOS big sur . :joy:

ok, I think I found it, it’s just be hidden

1 Like

I have the same issue. I have never gotten my chia to connect to wallet on macos 10.13.6 high Sierra no matter what version 1.1 till 1.23 today…

Any ideas?

I have made sure firewall is happy with chia

I don’t seem to see a .chia folder anywhere even if hidden.

I turned on console via developer and do see the following:

main.js:1 Failed connection to wss://localhost:55400
DevTools failed to load SourceMap: Could not parse content for file:///Applications/Chia.app/Contents/Resources/app.asar/build/renderer/js/293.js.map: Unexpected end of JSON input
main.js:1 Failed connection to wss://localhost:55400
DevTools failed to load SourceMap: Could not parse content for file:///Applications/Chia.app/Contents/Resources/app.asar/build/renderer/js/main.js.map: Unexpected end of JSON input
main.js:1 Failed connection to wss://localhost:55400

I had the same issue with cannot connect to wallet way back when installing on my 2009 MacPro with High Sierra. Turns out that the minimum requirement is macOS Mojave from the github page

MacOS requirement is not mentioned at the chia.net main download page:
Download - Chia Network
unless you follow the “Installation instructions” link to github

Thanks Scavenger… that is good to know…

I am also stuck with old 2011 MacPro and so I won’t be able to run it…

If your Mac still has the original GPU, it probably does not support Metal. You can upgrade to Mojave but you’ll need an upgraded GPU that supports Metal.

Awesome information… I will be sure to follow up and see if I can do anything further.

I had tried the upgrade and it already told me I was ineligible…

A serious mahalo. I’ve been on the out for months and super frustrated. Your email got me back in. Cheers.

Press these keys to unhide/hide hidden files/folders :

shift + command then period (dot key)