Mad Max Plotter, some test results, some general info

Thank you very much. Will test it tomorrow when my parallel plots finish, on an R720 with 32 threads and ramdrive. Its a dual E5-2650 V2 now but I’ve got some E5-2670 V3s arriving which will bump me up to 14000 CPU Marks from 10000. I’m quite looking forward to it, I haven’t done a CPU upgrade for years.

1 Like

128gb of ram cheaper than multiple 2tb nvme. anyone with a ramdisk and a fast CPU should be getting pretty close to 30 minute plots, i’m at 35 now, hopefully able to shave a few minutes off here and there.

and the dev is still optimising it every day.


I like to leave at least 1 thread for the system, which with their current version does not work. All threads maxed out, that should be fixed.

So you are using 128gb of ram as the 1st temp or as the 2nd temp? And how many RAM slots you need? Since you need some spare RAM for the system, right?

check the repo at GitHub - madMAx43v3r/chia-plotter

taken from repo instructions:

 -2, --tmpdir2 arg    Temporary directory 2, needs ~110 GiB [RAM] (default = <tmpdir>)

yeah 110gb ramdisk to tmp2, nvme for tmp(1)

i’ve tried a single nvme for tmp1 and 2 in raid0, some aspects of the phases are faster either way, it’s basically a wash there. phase 2 i noticed was maxing out my IO re: write speed, in phase 2… but IOPS likely take a hit in raid0 so overall it’s within seconds either way and not worth worrying about unless your nvme is bad.

for me, having a 32 core CPU, i needed more than 128gb of ram since 32 cores uses more than 128gb of ram all up, 16 cores should be fine with 128 total.


I’ve been thinking to get your specs, but somehow that’s now too late to get it ready since it will take weeks to get all the parts at hand.
You are set with those specs :slight_smile:

1 Like

ideal plotter to build right now from new parts would be a 5950x, single decent nvme and 128gb of ram, easily 50 plots a day with zero messing around/optimisation with this plotter.


32GB DDR4 times (what) 8? If the High-Core CPU alone takes 128GB RAM?

yeah 128gb is enough for 16 cores, not enough for more than 16


Multiple smaller NVMEs would be better because you have more sustained write. 128gb of ram is also overkill so I’d say 64gb is optimal for that machine.

i tested out 1 nvme vs 2 in raid0

certain aspects of certain phases were faster or slower, overall it’s probably a wash, maybe in favour of a single decent NVME since raid0 hurts IOPS somewhat.

pretty surprised cos phase2 i noticed was 100% maxing out my write speed of a single nvme, but raid0 didn’t help.

you NEED 128gb of ram to use this plotter optimally, it saves most of the time by writing most data within a 110gb ramdisk.


One plot took me 2091.63 sec on a 5900x with two 980 pro as temp drives. Calculated on a daily basis, that is exactly as fast as running 16 in parallel with plotman, getting around 41 plots per day!
The main advantage here is that much less RAM is required and jobs are running one by one, so I don’t have to wait hours any more before plots end in order to do some maintenance! Really cool!


Struggling to get this to run. I installed vc_redist.x64 then tried running it from powershell like this with my pool and farmer keys and got this:

PS C:\Users\djdem\OneDrive\Desktop\MaxPlotter> ./chia_plot -1 -p ************************************************** -f ************************************************** -2 R:\temp\ -t E:\temp\ -r 28 -d E:\plots\
Final Directory: E:\plots\
Number of Plots: 1
Process ID: 11088
Number of Threads: 28
Number of Buckets: 2^7 (128)
PS C:\Users\djdem\OneDrive\Desktop\MaxPlotter>

It stops after 2 seconds.Same result using the .bat file.

1 Like

Check CPU temperature

Monitor temperature with Core Temp app

34 deg C nothing running at the moment, via core temp

1 Like

Others tried from the above link seems working without issue
Open the bat file in Notepad, and have a closer look at how I chose directory path to the Max folder.

1 Like

Didn’t you forget to set a temp directory?
Because in the problem above, you don’t have any temp drive at all.
I see only a final directory set.

I got it right if I run the bat file it opens prints the first four lines:
Number of Plots: 1
Process ID: 11088
Number of Threads: 28
Number of Buckets: 2^7 (128)

Then stops. Thanks for your help, but I cannot ask any more of you, it is not your software and is very early in development.