Madmax gigahorse starting farmer error

Hi, I have a problem with running the farmer from the command line on Windows 10 Pro. Before that, I used the Chia application while the plots were not compressed. Now I have transferred some of them to the C8 level using Madmax Gigahorse (version 1.8.1) . When I start farming , the following is issued:
‘’’
PS C:\chia-gigahorse-farmer> ./chia start farmer
Daemon not started yet
Starting daemon
Traceback (most recent call last):
File “C:\CHIA-G~1\chia.py”, line 4, in
File “”, line 1027, in _find_and_load
File “”, line 1006, in _find_and_load_unlocked
File “”, line 688, in _load_unlocked
File “C:\CHIA-G~1\chia.py”, line 139, in
File “C:\CHIA-G~1\chia.py”, line 135, in main
File “C:\CHIA-G~1\click\core.py”, line 1130, in call
File “C:\CHIA-G~1\click\core.py”, line 1055, in main
File “C:\CHIA-G~1\click\core.py”, line 1657, in invoke
File “C:\CHIA-G~1\click\core.py”, line 1404, in invoke
File “C:\CHIA-G~1\click\core.py”, line 760, in invoke
File “C:\CHIA-G~1\click\decorators.py”, line 26, in new_func
File “C:\CHIA-G~1\chia\cmds\start.py”, line 23, in start_cmd
File “C:\CHIA-G~1\asyncio\runners.py”, line 44, in run
File “C:\CHIA-G~1\asyncio\base_events.py”, line 649, in run_until_complete
File “C:\CHIA-G~1\chia\cmds\start_funcs.py”, line 64, in async_start
File “C:\CHIA-G~1\chia\cmds\start_funcs.py”, line 42, in create_start_daemon_connection
File “codecs.py”, line 322, in decode
UnicodeDecodeError: ‘utf-8’ codec can’t decode byte 0xc5 in position 29: invalid continuation byte
PS C:\chia-gigahorse-farmer>
‘’’
Before that, I ran the Gigahorse farmer on two nodes in this way and there were never any errors. What could be the reason?

Consider asking in the madMax discord.

When I started gigahorse I used start_farmer.cmd to make it easier… it will pop up another cmd window and start the needed daemon and parts as needed.

Starting from Windows PowerShell, I use .\chia.exe start farmer

Make sure you launch PowerShell from wherever you have the Gigahorse application. You appear to be using a forward slash instead of backslash. Not sure if this makes a difference?

you also need to use chia.exe not just chia but not sure if this is the cause of your problem.
so .\chia.exe start farmer . Garethrn gave the correct command above but didn’t emphasize this point :slight_smile:

I seem to recall having similar after upgradein to 1.8.1 and I ended up deleting the config file and recreating it which I think solved it (It was very late at night and I don’t remember exactly what I did, everything is a bit muddled in my head :stuck_out_tongue: )

Make sure to restart everything properly, like rebooting the machine.

1 Like