My sync remains 0 for last two days

I have 293 plots and I’ve been farming regularly for almost a year. My sync never had a problem. But for the last 2 days, my sync remains just 0. Connection status shows connected. Now I know about dust storm that messes up the servers. So is it because of dust storm that I my node doesn’t sync, or is there a damaged file etc and I’d better reinstall the program?

did you try a reboot of your machines already?

I’m using my PC to farm. If you mean if I tried rebooting it, yes I did it already.

Could you provide more info about your CPU and where is your blockchain db (on HD or SSD). How many peers do you have, are all at the full height? Do you see spinners?
Screenshot would be helpful, also from your Task Manager.

CPU: Ryzen 7 2700x
My plots are on HDD [2 X Seagate External HDD (8TB+10TB), 1 Seagate HDD(8TB)]
You can see my peers below. They used to be active until yesterday. Disks with letter J, K and L are where my plots are. They are not working at the moment but they are active actually.

And that is my node status at the moment

Also I disabled the hard disk turn off like this so they can keep working on idle mode or power saver mode. In fact, I’ve been turning my PC on power save mode during the day and it never occured any problems with farming.

I cannot say that I understand what is happening.

Clearly, your box has problems with your peers, as the Up/Down values are all at 0. This is really bad. This is also the reason that your Blocks section is empty.

If your peers were active till yesterday, this may suggest that your either blockchain or wallet db is corrupt (maybe got corrupted when you shut down your computer yesterday). However, usually those corruptions manifest in plenty of spinners all over the board. Still, it doesn’t look like your box is trying to make those peers work, but rather something didn’t start right, and disabled the peer data exchange process (e.g., corrupt blockchain db).

Maybe you can:

  1. Stop chia
  2. Reboot
  3. Delete debug.log file
  4. Start chia
  5. Let it run for a couple of minutes
  6. run “findstr ERROR %userprofile%.chia\mainnet\log\debug.log” and paste it here

However, your CPU is rather weak. I would suggest that you drop your peer count down to 40 or 20 or so in your config.yaml:

  target_peer_count: 20

The mem pool is slightly elevated for the past couple of days (and was elevated for about a week/two few days before), but not to the point to knock off your box (IMO), as we don’t see any stress on CPU or your c: drive.

I would also suggest that you move your both dbs to your e: drive, as having blockchain on your OS drive is not really good (neither for chia, nor for your OS SSD).

Your plots look good, so that is not the problem.

So grab those ERRORs from debug.log file, as those may shed more light on what is going on with your box.

Also, maybe you could do one more screenshot. Switch your Task Manager to Processes and expand your Chia line (to see all sub-processes). You should have there around 15 or so sub-processes.


Thank you for your very detailed reply. I think I’ve solved the situation. I removed blockchain file under Chia (approximately 64 GB big). then restarted the program, waited for a couble of minutes and it has started to sync finally (down from zero though). So there’s a strong possibility that, that blockchain file was corrupted. Here’s a screenshot.

1 Like

Which version of Chia are you running?

I am asking, because some of the previous versions will sync, but slower than new additions are added to the blockchain. So you could increase by 100 ticks, while the overall height increases by 150 ticks. This will result in you never getting fully synced.

The latest version will get you fully synced.

1 Like

I’m using the version 1.2.11. I think it’s the latest version right now.


Glad to see you sorted! Actually, I forgot to ask you to check your free space on c: drive. Although, blockchain additions are in rather small chunks, so in order to have this to be an issue, your drive should be basically full.

I would still suggest reducing the number of peers (due to your CPU), and moving those dbs to e: drive. That will improve your syncing times in the future.

Also, if you intend to sync from scratch, that will take few long days. I would download blockchain db from either or elysiumpool (search forum for it). That will get you up to speed in an hour or so (plus several hours for wallet db sync).

1 Like

Thanks for the advice. I’ll check the reducing peer numbers as well. Is it trustable to download a blockchain file from an unofficial source like this?

Well, there is no “official” place to download blockchain db. There are arguments both ways. To me, those arguments are more around “the spirit of …” vs. your time wasted.

I don’t see problems with using one of those two sources (plenty of people have used them). I wish, chia would have acknowledged the syncing problem and provided a work-around (e.g., by working with those two entities to provide a “chia blessed” db while this issue is affecting so many people).

I agree. I have only 293 plots so I don’t have too much loss while waiting for sync but for someone who farms with 500 plots for instance, waiting for 2 days is a big big loss. Hope Chia can find a solution to this somehow.

1 Like

may I ask why you would regard a 2700 as “slow”?
It’s quite confusing to me as some pps here were using raspies. Granted, they fall out of sync in the duststorms but a 2700 is roughly faster by a factor of… 10(?)

I’d find a 2700 plenty fast for farming chia.


It is slow just with respect to syncing process. It is a fast processor, as you said, and can pull the job fine. However, during the syncing times when you already have about half of blockchain db downloaded, a single core performance starts to count more than anything else. The main start_full_node process is unfortunately either single threaded or synchronized threading model, as such cannot scale with your CPU. What also interferes at that time is the number of peers that process needs to handle, and db access that is rapidly slowing down. So, you need to tune those three components at the same time, as having just one good will not pull the job.

And you are absolutely right about RPi. However, RPi will really suck during the initial sync phase (starting from scratch) as it just doesn’t have enough free cores (initially, the number of cores is really the key, as that main process is not yet overwhelmed). Once you get it synced, when you trim your connections, and move your blockchain off your SD card, it can actually ride through at least some dust storms. So, I would be rather careful when stating that RPis cannot pull through dust storms (if well tuned).

So, again, nothing wrong about that 2700, just factoring all components that are at play.