New Harvester Not Attaching

Good Evening,
I built a new box that will eventually be my new Farmer box. Before I get there, I need to make it a harvester to migrate my plots before hand. I have done this on a couple boxes. I have not done this in a while and I have hit a roadblock. The key phrases were loaded correctly on the new harvester and the public keys are all the same on the harvesters and the farmer. I modified the config.yaml to have the ip address of the farmer. When I launch the harvester, it never attaches to the farmer. I do not see it listed under the harvester network.
I will mention that the new harvester was built on 2.0.0 and I did not see it attach to my older farmer. I updated my farmer and harvesters to 2.0.0 and still the same lack of attachment. Is there a missed step?

Are you running Windows?
Are you using Defender as your firewall?

Turn it off on your farmer box for a few seconds. If the firewall is the issue, then your harvester should connect in 1 or 2 seconds – it will be almost instant.

If your harvester connects, then it is a firewall issue.
If your harvester does not connect, then it is something else (could also still be a firewall issue – but not likely).

Do you have any other remote harvesters?
Are they showing up?

If you are referring to your 24 words…
harvesters do not need them.

Harvesters need only a copy of the farmer’s “…\ca” directory, and the “init” command syntax to have your harvester utilize those files.

Thanks for the quick reply.
Yes, I’m running Win11. I dropped the firewall for both public and private on the new box and it doesn’t connect to the old farmer. I even tried telnet from new box to old box on the port 8447 and it connected so it’s hitting the ip and port. Old box has firewall disabled for private networks.

Old box doesn’t want anything to do with the new box.

I got the impression that your new box is currently your harvester.
If that is correct, the firewall test should be on your farmer (the server).

I am no expert, but a firewall might filter down to the protocol level, and I have doubt that Chia’s harvester → farmer protocol is the same as telnet’s protocol. I could be mistaken. But it is worth dropping the farmer’s firewall for a few seconds to rule it out.

Did you copy the cert/ file to allow them to communicate?

1 Like

That was it!
In v2, the directories did not align and someone else didn’t mention it. Again, it’s been a while since I added a harvester and forgot the step,

1 Like