Plotman: Keeps Starting New Plots

I’m running into an issue with plotman that I’m wondering if anyone else has run into. I’m on an M1 Macbook Air trying to plot to an external SSD via Thunderbolt 3. Plotman is configured to run only one plot at a time, but every time plotman refreshes, it starts a new plot. For reference, I don’t have any issues plotting in serial with the GUI (parallel is another question :sweat_smile:)

Activity Monitor shows a new chia process spins up each time, too, but for some reason the plotman logs stop updating.

I’m not sure if this is a bug with plotman or if I’m just Doing It Wrong ™, so I figured I’d start the discussion here. If it’s plotman, I’ll file an issue on GitHub.

EDIT: I got some help from a friend. Turns out you need to install the plotman development branch.

pip install --force-reinstall git+


I had the same problem on a new Mac and this fixed it in an instant. Thanks for sharing!


Thanks for the tip! This unblocked me as well, and I tried to capture it in a pull request for the install README:

Credit back to this post.

Thanks @s.preso!


I have the same problem where it looks like it tries to start a new plot every time it refreshes but just adds it to the ‘logs’ section at the end of the ‘plotman interactive’ screen. I’m on linux not on Mac though, is that github link still relevant in this case?