Plots not found due to misconfigured farmer_peer

Hey y’all - I’ve renamed one of my external disks today and afterwards all of my plots appeared in the “Not found Plots” section underneath “Plots”.

The volume is properly mounted, I’m using Chia 1.1.2 on macOS and the “Not found Plots” even lists all of my plots correctly - but I’m not farming. I’ve also tried turning everything on and off again™️ and removed/added the respective plot directories.

Running chia plots check via CLI lists and successfully tests all plots.

Appreciate any hints or ideas - thanks!

Did you add the new directory location in config.yaml?

Thanks for the feedback @roybot but I meanwhile found the issue. I had misconfigured the farmer_peer property previously (and assumed I remember to change it back) which then led to the following errors in the log:

2021-04-29T21:08:05.869 harvester chia.plotting.plot_tools: WARNING Plot /Volumes/chia-plots-1/plot-k32-2021-03-26-20-48-caffeebabe1337.plot has a farmer public key that is not in the farmer's pk list.

I have changed the property back to the default (localhost:8447) and now it works again - sorry for the confusion.


Glad to hear it :slight_smile:

Why did you change farmer_peer initially?

I wanted to connect to another peer using the CLI and had issued the command:

chia configure --set-farmer-peer

… but this command does not add another peer - instead, what I had wanted to do was the following:

/usr/bin/curl -s --insecure --cert ~/.chia/mainnet/config/ssl/full_node/private_full_node.crt --key ~/.chia/mainnet/config/ssl/full_node/private_full_node.key -d '{"host":"", "port": 8444}' -H "Content-Type: application/json" -X POST https://localhost:8555/open_connection > /dev/null

Eventually I forgot to revert the effects of the initial (wrongly used) command.

2 Likes is just a placeholder for an IP address, you didn’t actually put, right?

I did not put in there :slightly_smiling_face:

Actually, to give you the full context, I’ve written a cron job that would establish a peer connection every day shortly after my ISP assigns a new IP since my node always fell out of sync shortly thereafter and I had to manually trigger the reconnects the next morning.

1 Like

Ah, that’s a good data point. ISP dynamic IP addresses can be an issue.

Thanks for updating the title to reflect the actual issue @codinghorror :pray:

1 Like

Thanks for documenting the fix! Hopefully it can help others in the future! :bowing_woman: