Plots not shown in Gigahorse


I am running GigaHorse with C7 plots on 36 x 22TB hdds ( 9864 plots ). Since yesterday, when i cloned my SU630 240GB to a 500GB Samsung EVO 870 and updated wallet and gigahorse to 2.1.4, i am not seeing 274 plots from one hdd. Config is the same, all 36 hdd are running well in windows and are added in gigahorse.

How can i determine what hdd is not farming ?

I do not know of a quick method. I have three suggestions that involve some time, but should reveal the culprit drive. My suggestions are based on your assertion that one drive is not farming (your harvester is not seeing one drive’s plots).

  1. In your config.yaml, comment out the first drive that you have listed. Save your edit. Wait 2-3 minutes to see if your plot count changes.

If your plot count changes / lowers, then that drive was being seen by your harvester (it is not the culprit). So remove the comment in your config.yaml file, save your edit, and wait to see your plot count go back up.

Repeat for the next drive.
Eventually, when you comment out one of your drives, your plot count will not go down. That would mean that it was already not being included by your harvester. You found your culprit.

Make a copy of your config.yaml file, before you do any edits.

  1. You can create a directory on one of your drives. Then, on that drive, move your plots into that directory (since it is on the same file system, the move should take less than one second). Wait 2-3 minutes. If your plot count goes down, then that drive was being seen by your harvester.

Move your plots back to where you had them, and wait for your plot count to go back to where it was.

Repeat for your next drive.
Eventually, when you move your plots to some other directory, your plot count will not go down. That would mean that that drive was already not being included by your harvester. You found your culprit.

  1. You can power off one drive, wait 2-3 minutes, and see if your plot count goes down.
    If it goes down, then that drive was being seen by your harvester. Power it back on, and wait until the plot count goes back up.

Repeat the power off / on procedure, until you find a drive where powering it off does not change your plot count. That will be your culprit.

There might be some 3rd party tool that would quickly identify the drive in question. I am not aware of any – but they might exist. I would not trust any 3rd party tools for my Chia boxes.

Perhaps someone else will offer a faster, easier solution. If not, you have three options to nail down the culprit.

Number 1 would be my choice. But you have to be extremely careful with your config.yaml edits. One character (even a space missing or in the wrong place), and you will have a world of hurt. So have a copy of your config.yaml file made, before you do anything.

And in case you are not aware, to comment out a line in your config.yaml file, insert a # symbol as the first character of that line. Also remember that Chia will not recognize any edits to your config.yaml file, until you save your change to the file.

Lastly, Chia can take 2 or 3 minutes to acknowledge your change (for any of the above three choices).

Did you start the new 2.1.4gigahorse first, did you see all the hard disk before you cloned the disk?

If he had a running system and saw all the drives, had them added into the chia gui. Installed the new gigahorse 2.1.4 then chia 2.1.4 all should be running.

This really depends on what the plot interval refresh is set to in the YAML, mine is set 3600, or 60 minutes. Best option would be to force a refresh, which can be done on the plots tab.

If recursive scanning is on, this probably won’t work, it would also defeat option 1 as well.

I use recursive scanning, and only have 2 lines for plots in my yaml, all of my drives are mounted in C:\Plots and with recursive scanning, it scans all the mounted drives in that folder.

Perhaps turn off recursive scanning if it is on, use the GUI “Manage Plot Directories” to delete all folders, then force a refresh, then one by one add the drives/folders back forcing a refresh each time and checking plot count increase.

@Ronski You make a case for not using the recursive scanning feature.
I do not use recursive scanning, as it adds another level of problem solving when trouble shooting a problem such as this.

Recursive scanning is helpful. But I see potential problems as outweighing its benefits.

Adding a new line in config.yaml, when you add a new drive, is simplistic, takes a few seconds, and never needs to be repeated for the same drive. You set it and forget it.

Your other points are correct. But my posting was long enough, and is why I offered 3 options.
I tried to stay out of the weeds, and offer only relevant help.

As to the 3600 seconds refresh value in your config.yaml file, why did you make it that long?
I never changed mine from its default 120 value.

That is why I wrote 2-3 minutes, as it is reasonable to assume that @cl4ud1u did not change that value. If he did, he should know that he would have to substitute his value for the 2-3 minutes value that I wrote.

How do you do that?

Go in the chia GUI, click plots, upper right hand side…


Add plot directly manualy from gui

I find recursive scanning far better, I don’t need to add multiple lines to the yaml (and risk breaking it*) or add the drives through the GUI, and I’ve never had an issue with it.

If I need to trouble shoot, I can very easily turn recursive scanning off and add the drives one by one via the GUI, or via CLI, think I once had a batch file to do it.

Do you add new plots every two minutes all the time? Probably not, and I certainly don’t, hence I don’t see the point of scanning the drives every two minutes. Even when I was replotting I didn’t change that value, I just manually refreshed it if I was on the computer, or just let it do its thing.

*when I used to edit the yaml when Chia was running, it would often break, so I now leave well alone, and always shut down Chia prior to taking a backup and editing it.


I found the problem. I had a folder with the plots on one drive and all other have plots direclty on hdd without folder. For sure the same was before, but i remember i had 274 plots x 36 hdd = 9864 plots total.

Nevermind, thank you all for helping!


Always put your plots in a folder…

1 Like

Can you say why create folders?

You keep things organized.


Eu am toata infrastructura pe ubuntu 22.04.

in Windows nu stiu ca sa te pot ajuta.

PS: gandeste-te sa plotez in NOSSD C14. Nu stiu daca C7 mai e profitabil.