Plotting Always Stays On Same Drive Regardless Of What Final Directory Is Set To (SOLVED)


I seem to have broke my plotter and have tried a few things to get it back in working order. I’ll go over what I did and a list of what I have tried doing to fix the issue. Please let me know if I’m missing any important information.

I was using the NVMe my prebuilt PC came with. Plotting from NVMe to HDD was no problem. Then I decided to move the Windows OS onto a dedicated SSD and upgrade my NVMe to a 2tb with faster read/write speed. I cloned the OS over to the SSD and installed the new NVMe as well as some faster sticks of RAM. Now when I try to get a plot going it always goes to E:\Chia Temp to E:\Chia Temp even when the final directory has the HDD selected.

Things I have tried doing to fix this:

Completely reformatted all drives (except the HDD that has my plots) and install a fresh Windows OS onto the SSD.

Took off all the new hardware (faster NVMe and SSD) and reinstalled the original NVMe with the OS I had been using. I did leave the new RAM in however, not sure that would change anything.

Went into BIOS and reset everything to default.

After all this my plots still start and finish on the same drive. I’m not sure what else to try. Please let me know if there’s something I’m missing or can do to solve this.

Thank you for your help!

EDIT 1: I may have tried to plot more than my CPU could handle. Going to try and do the same amount of plots as I had previously and check how fast it completes (if it completes) and report back.

EDIT 2: Looks like they finished in just over 8 hours. Looks like I never really had an issue at all and was just plotting too many at once. Thanks for the help!

Make sure you don’t have “Exclude final directory” marked on the GUI

I looked and it is not marked. Generally I have left default settings alone.

Look at your plot logs and see if it is attempting to even copy them to a different drive.

one hell of a weird problem
good luck to follow this subject

I can only post one picture at a time, I’ll post the 2nd one after this.

This is what I have selected.


And this is what the log shows

Copy what the last 12 lines or so say on a completed log, and put it here.

This is the most complete log I have since I just made a new one for this example.

Ok, go to (Operating system drive):\Users\ (Your username) \.chia\mainnet\plotter . In that folder, it has all of your completed log files. Click on one that is totally complete. Copy the last 15 lines from it.

Unfortunately I don’t have any completed logs. I haven’t gotten a single plot to phase 4 since my problem started. I’ll let one run as long as I can to see if I can get that info and share it when it’s available.

Wait!?! Are you worried about the part where it says plotting progress into temporary dirs: d:/ and d:/?

Yes, it used to show a different drive at the end.

Dude, don’t worry about that. Mine says that too. I don’t know why, but it always goes to the correct final directory. I’m assuming it is because they updated the GUI. Let one complete, and I’ll almost bet it will be fine.

Thank you. I’ll try that and see what happens.

Also, delete your pictures. It is showing some keys. I don’t know what someone needs, but you are showing some info that I wouldn’t.

1 Like

Yeah I was thinking there might be some sensitive info in there. I have some hardware on it’s way and I’ll probably set up a new account once the new rig is set up.

EDIT: It did say public key so I don’t think it was anything too important, but I have no idea.

Well, how did it turrn oout?

The problem was all in my head. The issue I think was that I was trying to plot more than my CPU could handle. I’m experimenting with the delay feature and the results look promising. Going to bed now so I’ll see how it goes in the morning. Thank you for checking back with me.

1 Like