Plotting stuck at 100%

Seems that my very first 28 hour long single plot on a small USB 2.0 drive is stuck at 100%? I’m not sure if this is a bust or what? I’d like to salvage this initial plot if possible. Any suggestions?

If you tap the 3 dots and look at the log you’ll probably still see some movement. It’s copying the final 100 gig plot to it’s final destination, if the disk is slow then this can definitely take a while!

1 Like

Yeah. I think that’s what it’s doing here. Sadly, I’m going to turn around and move it from that location to a new disk I just got. Now I’m on to my second plotting attempt. I’m trying 2 in parallel to a new 8TB external USB 3.0 drive. I’m just playing around right now until I get the hardware tomorrow to build a real plotting rig.

Thanks for the feedback.

No worries! Parallel only works well if you’re doing it on two different disks. Otherwise you might want to stagger the plots. More info in this thread: Optimizing Plotters

You are referring to HDD plotting, right? I’m about to build a new system with a 2TB NVMe drive. I’m planning on plotting 4 or 5 in parallel on this and then moving them to my HDD storage for farming.

I meant plotting is happening on your absolute fastest drive, so you Navne.

So this is great, with 2 drives, if you want you could try to run 3 (or more) in “parallel” on each drive, the trick is to stagger them, so don’t start them all at the same time. You want to start the 2nd one on each disk around 55% into the first plot and the 3rd one 55% into that 2nd plot on each drive. The first half of a plot uses the most resources so you want to make sure to give it all you have. The other thing is to start each plot with 4 threads. This combo seems to give the best plotting rate.

In essence you’re doing 2 in “pure” parallel at all time (2 drives) while some of the crunching happens while a plot is coming down from using resources so you can kick off a new one.

1 Like

I assume by resources you are meaning IOPS on the drive in question? The system I’m going to be working with has plenty of CPU and memory for running 4 in parallel so I’m assuming that the disk IOPS is the limiting resource. I wonder if anyone has measurements of IOPS for a single plot?

The drive in question that I’m going to be using is a Sabrent Rocket 2TB. This is rated for for about 500k write IOPS with a write speed of about 2750MB/s. So if this is truly the limiting piece of the puzzle here, I’m curious as to the IOPS and write speed metrics for the plotting process.

Chia is designed to be resistant to performance improvements, the IOPS, your CPU and your memory all play a role. No matter how fast your drives are, how beefy your machine is, you can expect a single plot to take about 5-7 hours on even beefy hardware.

Make sure to have a read on optimizations with staggered plotting in the topic I linked earlier: Optimizing Plotters


Interesting, is there any place where this is spelled out as a goal? It makes total sense to me.

Even people with 512gb RAMdisks (!) were getting 3+ hour plots from what I recall on Reddit?

From what I’ve seen, plot speed is highly reliant on single core speed (Phase 2, 3 and 4 are single thread). Right now the Ryzen 5000 series have the field I believe. Not sure on the Enterprise side though.


100% agree, I still can’t believe the 4.5h plot times I get from i9-9900ks with its juiced 5ghz on all cores. Disks are just regular old 970 pro and 970 evo, and the 970 evo plots are barely any slower…


I was able to perform a few speed tests while I was waiting for drives to show up. The fastest I was able to achieve was 12505 (3.47hrs) on the 5900x.

6 threads, 3416 RAM, Raid0 on 2 NVMes, and no other plotters going. Linux is 10% faster and I plan to do speed tests again on there once I run out of disks again.


Good question, I seem to have that stuck in my head but can’t find good info on it. But it would make sense to make plotting hard so as to keep farming under control.

hey, I’m using win10 GUI for plotting for now… just to clarify, when you said - ‘’ if you want you could try to run 3 (or more) in “parallel”
you meant the plot count of 3 ?
and the staggering is ‘the delay before the next plot starts’ right?
I was thinking about putting here 3-4 hours… that way if I have 476GB Nvme I can run only 2 in parallel right?
It is always 1 parallel per Nvme and the plot count is determined by the temp nvme capacity? I don’t know if I understand this correctly :confused:

Also my setup is → x299 taichi with i9-7900x ES, 50GB RAM, different 467gb and 948GB nvmes, I’m experimenting with different plotting styles to get most per day of course, I also tried multiple HDDs for plotting but it takes forever, now with hdds I will go to try putting secondary temp file to the final directory see how it goes, thanks for any suggestions :smiley:

1 Like

I’m using the win gui on an offline machine, stuck at 100% for 40 mins now…

did i read somewhere you can just remove the .temp part off the file?

last line of the log is “final size…” but it looks like i have 2 temp files around 106gb each in both the ssd and hdd drive

Hi, I have the same stuck at 100% issue.
As pilot i have plotted on my PC wit a 500gb sata ssd and into a 1.5Tb Sata hdd (~8 hour plotting time).
I have build a new plotting machine with 970 pro nvme 1Tb ssd and a WD black 4Tb sata hdd. The 1st plot i plotted stuck at 100%. Almost 5 hours now just copying? Phase 4 finished.

OK. I have solved my own issue, but it can be useful.

It was because of a bad SATA cable.

1 Like

Hello friends. My plots are stuck at 100% and has a copy error external drive. I do not want to lose it because the files are stable. I’m not closing GUI. How can I help you copy manually? Code line etc.

This is the error in log records.

Could not copy "D:\\Chia1\\plot-k33-2021-05-23-17-53-6ed26c8caa02445ba3d2e70028b65dad98276cc69fd64080ae7e57ea8072e715.plot.2.tmp" to "J:\\Chia7\\plot-k33-2021-05-23-17-53-6ed26c8caa02445ba3d2e70028b65dad98276cc69fd64080ae7e57ea8072e715.plot.2.tmp". Error Semafor zaman aşımı süresi geçildi.. Retrying in five minutes.

You can copy that file urself.
Just rename it to .plot

I’m trying to plot 100 GB plot (k32). I’ve given temp directory as C: (PC) and final directory as D: (external HDD)

The process is stuck at 100% and it gives the attached error.

When trying to copy the file, after renaming, from C: to D:, it gives message ‘file too large for destination’. My destination D: is an external HDD with 1 TB capacity. It has 650 GB available. Also confirmed that the drive format is NTFS.

Any steps I can take to resolve this? It took 5 days to get to 100%, so would love to avoid redoing it again.

Thanks in advance for the responses & help.