Pool farming without wallet sync not working?

Hi there,

I recently started replotting my small farm of plots to NFT plots with madmax and connected to a pool via the GUI on my windows 10 pc. While I was farming on my windows pc there was no problem with the plots so far, as I could see my partials beeing accepted by the pool on the pool dashboard with the launcher id/alias.

After I finished replotting, I moved the plots to my raspberry pi 4 with ubuntu 21.04 installed and started farming via CLI. For performance reasons I started the farmer with “chia start famer-no-wallet” and confirmed that the full node is indeed in sync. Also “chia farm summary” and “chia plots check” were showing everything is fine.

But when I go to the pool dashboard with the launcher id from the windows 10 chia GUI which I checked earlier, it does not show any new partials being submitted by my farm and the estimated plot size therefore went down to nearly zero. So my question is, since I heard that the pool contract of my plots is somehow saved in the blockchain, do I also need a fully synced wallet on my rasbperry pi farmer or is a fully synced node enough to ensure that my plots are farming towards the pool with the pool contract id that I used in madmax to create the plots?

Do I maybe have to use a different launcher id, now that my plots are on the pi? But if so, where to find that launcher id via the CLI?

Any clarification or help is more than welcome!

Thank you!

2 Likes

In the exact same situation! - did you ever find a solution?

Moved all my NFT plots to my 8GB raspberry pi 4, but they aren’t reporting to the pool. Only way the pi will run Chia without hanging and running up the RAM and disk locks is by starting farmer-no-wallet - seems to be either a bug in the code or an excessive demand for resources when wallet gets involved.

The wallet shouldn’t be necessary since your full node has a synced copy of the blockchain. Try leaving the pool and joining again (always wait the completion of each process).

I tried just running the node - it was farming but nothing was reported back to the pool.

I did not want to deal with any sid effects or downtime of leaving and rejoining the pool, also the Chia docs are unclear about whether the wallet is needed for such operation.

I solved this issue by copying the wallet folder of my original machine. I had originally bootstrapped my raspberry pi node by copying just the ‘db’ folder, but now that I copied the wallet as well, the RPI has been working fine for a couple days running full farmer+wallet.

My wallet is stuck and not syncing. I’m going through a re-install and I can honestly say that I’ve had every issue you can imagine. I cannot see my pool. Plotting did freeze again. When I could plot fine before and had no sync issues before, then with updates, now nothing seems to be working? I’m commenting here because wallet sync is not working for me, has stuck at the same location even after deleting and starting from scratch. Always easy to troubleshoot when there is a large userbase which I think there really isn’t unfortunately.

It seems to work without the wallet. I just noticed the first partial was sent to the pool and I’m running chia with farmer-no-wallet.

Make sure that the config.yaml on your farmer contains the pool_list key. I had to copy it from my main machine where I created the plot NFT with the GUI and a fully synced wallet.