[Solved] . ./activate ; chia / "chia status" does nothing and returns nothing; completely silent

Edit: my gosh! I figured this out and it was absolutely the dumbest thing: I had added chia as an alias in my .bashrc, which masked the proper function. So, problem solved! But the crazy thing is, I was so clueless that I even created the same alias again, in the working account - which broke it - which finally tipped me off about what was going on.

Mods, I don’t know whether to delete this post or leave it as a warning/case study of "double-check your premises"


(Sorry for the slightly awkward title! I found this a hard problem to search for; hopefully if anyone else has this problem they can find this thread.)

So I’m trying to run Chia on my Raspberry Pi, and something’s gone wrong - possibly with the Python installation. Chia simply doesn’t do anything with my user account, but with another user account (in the same directory), it works. Take a look:

s@pi:/home/s/chia-blockchain$ . ./activate
(venv) s@pi:/home/s/chia-blockchain$ chia
(venv) s@pi:/home/s/chia-blockchain$ chia status

But! Log out, log in as admin, cd to the same directory:

admin@pi:/home/s/chia-blockchain$ . ./activate
(venv) admin@pi:/home/s/chia-blockchain$ chia
Usage: chia [OPTIONS] COMMAND [ARGS]...

  Manage chia blockchain infrastructure (1.2.6)

Options:
  --root-path PATH  Config file root  [default: /home/admin/.chia/mainnet]
  -h, --help        Show this message and exit.

Commands:
  configure   Modify configuration
  farm        Manage your farm
  init        Create or migrate the configuration
  keys        Manage your keys
  netspace    Estimate total farmed space on the network
  plotnft     Manage your plot NFTs
  plots       Manage your plots
  run_daemon  Runs chia daemon
  show        Show node information
  start       Start service groups
  stop        Stop services
  version     Show chia version
  wallet      Manage your wallet
  Try 'chia start node', 'chia netspace -d 192', or 'chia show -s'

(Note: “admin” is just another user, not root. I set permissions to allow admin into the directory.)

Does chia work, only silently, with the “s” account? Nope: chia keys generate/delete/add causes no changes if run by “s”.

So, am I right to think that it’s not the chia-blockchain directory that’s the problem, but rather, the user’s python or some such?

I’ve removed and reinstalled chia, build-essential, and python3-dev as in this guide: https://github.com/Chia-Network/chia-blockchain/wiki/Raspberry-Pi . I can’t remove and reinstall python3, because that would take down my desktop environment with it :grimacing:

So, how can I fix this problem for the “s” user? (I’d prefer to farm with “s”, and I’d prefer to fix any problems with python or whatever it is.)

So what was the resolution? The subject says Solved.