SOLVED -- Upgraded to v2 of the db... no plots showing up?

SOooo i finally got around to upgrading my db to v2. Also running the latest version of the windows Chia Blockchain 2.1.1

After synching I show I have no plots??! lol I still have the other db and files in the dir saved off but I am wondering where or what happened to show that I have no plots. Still have my wallet and contents.

Is there a step I missed to bring those plots back online?


Your config.yaml file tells Chia where to find your plots.
An upgrade should not have changed the plot location entries.

Which upgrade did you do first? The v2 database upgrade, or the Chia to version 2.1.1 upgrade?

After the first upgrade, was all well?

Did you save a copy of your config.yaml file, prior to the upgrades?

Take a look in your config.yaml file and see if your plot directories are listed.

1 Like

Some questions come to mind.

  • Are your plot directories still listed?
  • Are you farming compressed plots and have compressed plot support disabled?

Thanks for the speedy reply

–Which upgrade did you do first? The v2 database upgrade, or the Chia to version 2.1.1 upgrade?
I tried to update Chia to 2.1.1 first. That didnt take because of the db version I guess.

–After the first upgrade, was all well?
Depends… the upgrade to 2.1.1 tanked because I guess the db version needed an update… finally figured that out by reading something where the poster said… delete/remove your old yaml. After I did that I reinstalled Chia and it came up to the last synch point and then fully synched. New yaml of course but Everythings green.

–Did you save a copy of your config.yaml file, prior to the upgrades?
I did. But looking at the yamls they are quite different. Not sure what to copy or where to place in the new yaml if thats the fix.
In my old yaml I see the plot directories entry and the listed plots under them
In my new yaml I see plot directories [ ] Can I paste in my plots dirs there? anything go in that double bracket?
Lower there is recursive_plot_scan: false - does that stay false?

I guess im on the right track here… didnt know what I may screw up by screwing too bad with my yaml file…

Same thing I guess with pooling now that I have looked thru things closer. guess its more looking thru that yaml. Or is there something different thats needed?

Appreciate the help here really!

Hmmm frustrating…

edited in my pool info… did a reload via the app… it pops up instantly.

then tried to edit in my plots and now Chia wont launch. Sigh… Im guessing this is tied with the edited yaml.


renamed old yaml and removed and reinstalled… back to no plots and no pool but at least chia is running and fully synched lol.

Its gotta be something with how im editing the yaml… (notepad++)

Yes, you can paste directory locations from your old config.yaml file to your new config.yaml file.
But before doing so, take these two steps:

  1. Make a copy of your new config.yaml file.
    Always have a copy of anything that you will be changing, in chase you make a mistake.

  2. Use the GUI to add one or two plot directories to your new config.yaml file.
    That way, you will see the exact location in which they need to be placed, along with proper spacing and the “-” symbol that precedes each entry. A missing symbol or extra symbol or wrong spacing can result in problems.

If you are not using it, then it should be false.

1 Like

If you have all or some of the drives mounted in a folder then you can set this to true, and you only need to enter the root folders like below.

So in the below example with recursive scanning enabled I would only need to add C:\Mounts - Plots and any other directory outside of that folder.

PS. I should add, its very easy to break the yaml file, one mistyped space seems enough to break it and Chia, so I avoid editing as much as possible.

1 Like


Thanks for the suggestions and tips in resolving my self created mess here. Your help got me in the right direction

I created a new plot and instantly the others that were on the newer drive popped up (half filled 20tb) after that went to the yaml and basically copied and pasted the syntax from the saved back up to the new one.

I think I am missing some plots somewhere BUT… it better than replotting everything.

THANKS @seymour.krelborn
THANKS @Ronski - Dude Im going to look into that method. seems interesting and a bit easier to manage and sort.

Consider this SOLVED.