Super slow plotting

here’s my hp z440 workstation setup:
CPU: intel xeon e5-2680 v3 (12 core, 24 threads)
RAM: 64gb DDR4
SSD: sata ssd 120gb to run ubuntu 20.04 OS
NVME1: Crucial P2 2TB PCIe M.2 2280SS SSD (connected using pcie 3.0 adaptor 1)
NVME2: Crucial P2 1TB PCIe M.2 2280SS SSD (connected using pcie 3.0 adaptor 2)
GPU: NVIDIA NVS 300 for video output
HDD: 4x seagate 8t external HDD (actually only 2 of them connected)

All i did is install chia blockchain (it should be the new 1.1.7, but on help i see Chia Blockchain 0.0), mounted SSDs and HDDs increased swap to 16gb and changed swappiness to 10 (swap seemed it was the problem on my first 11x parallel test)
my first solo plot was 20gb ram, 15 threads, 128 and it took around 9 hrs to finish, i then tried to add 3 more parallel plots using 4gb ram, 4 threads, 128, everything seemed fine but the first got stuck at 31% no errors were shown on the log file, it was just freezed and after a few hours i decided to shut them down.
i also tried to remove completely the swap since my 64gb ram is more than enough and i tought that was the reason of the slow plotting speed but it didnt help.
i tried quitting plots, deleting all the nvme files and replot again but it struggles to reach 1% too,
i’m running 4x parallel plots 4gb ram, 3threads, 128, temp on ssd1 and saved on hdd1 + 3x parallel plots 4gb ram, 3 threads, 128, temp on ssd2 and saved on hdd2 and after 2hours they’re still at 4%.
I’m new to chia farming and ubuntu as well, i decided to run it for better performance, but i cant stand what is making my speed so slow without any shown error.
i tried running ram performance test and it was alright, maybe i’m doin something wrong with settings or plotting itself?
i’m pretty desperate, every help and suggestion will be very much appreciated

Well, here 60% time of doing a plot is actually on 31%. You have a lot of SSD memory and enough threads. Just go parallel with 3000/265 ~ 11 plots (with delay maybe 2 - 3 minutes) and I bet it will end up in 12-14 hours.

1 Like

thanks for your answer.
you mean it takes more to get from 0% to 31% than from 31% to 100%?
going parallel for a maximum of 11 was my intention when i started but actually my 7plots are still at 4% after more than 2 hours and it doesnt feel right, do you think 3gb ram and 265 buckets would help it somehow?

Did You add delays? Just do the full plotting and write here the final time, we will see if there is something unusual.

i tried without adding any delay, 7 plots seemed not so much for my system, but now after 3hrs and 45mins they’re all at 6%.
computing table time 1 was 1545.96s CPU (26.27%)
computing table time 2 was 9331.283s CPU (32.650%)

Remember, that it is not only about CPU, it is also about doing a lot on HDDs and SSDs. Cancel that, try plot in parallel 11 plots on different HDDs with 2 - 3 minutes delay and check where You are - but let them end.

1 Like

yeah sure, actually my nvme usage is 21% and 34% and temperatures are 50°c ish ~
what is that 2-3mins delay doing in fact? can it change that much the performance?

To be honest, for me delays helps with HDD copying at 100%. Without delays it takes around 3 times longer to copy the final file to final hdd. Don’t really know if it will change anything in Your setup.

1 Like

i tried continuing on my previous plots while i was sleeping and then at work, after around 18hrs they’re all at 16%
computing table time 3 was 21909.179s CPU (15.710%)
computing table time 4 was 31470.984s CPU (13.120%)
i feel the problem can be the ssd not working properly, maybe the ext4 format is wrong? or maybe the pcie adaptors are not working at 3.0 speed (i selected 3.0 speed on bios, but it also shows raid enabled but i can clearly see the 2 different ssd directories

It is the Crucial SSDs.
I also bought a 1TB Crucial P2 to use as a temp drive. It is unbelievably slow when having to deal with a sustained workload.
I changed to Kingston KC1000 and Samsung 970 EVO Plus.
It is a difference like day and night.

2 Likes

Yes! And it’s the same for me. In short, these SSDs are really bad! They are not for docking! Change your SSD. I also ordered new SSD from Samsung yesterday. So far, Crucial SSDs have 6-9 plots per day

1 Like

The point is, i need a huge boost, not a slight adjustment.
With 4+3 parallel plots it took 18hrs to get to 16% wich means something around 4 days to get em finished.
Do u think replacing thatvnvme with another consumer one could make it work in reasonable time (~10 hrs)?
And assuming that is the way to fix my slow speed, wich nvme would you suggest me to get with the same budget or slightly more? as european i can swap to sabrent rocket q or maybe adata xpg SX8200 pro adding 100€ or so to my crucial price

Any suggestion on the nvme choice? Budget 450€ for 3tb

Use madmax plotter! I have 1 plot in 6200 seconds

1 Like

Samsung 970 Evo plus 1tb is about 140€ i think. Using it and getting 2821 sec Plots with madmax

1 Like

@Pub I have the same NVMs and I am actually plotting faster using my HDD as my temp and final dirs at around 8 hours per plot. I am also thinking on buying different drives but I’d like to try madmax plotter first to see if there’s any improvement.

Has anyone tried madmax using the Crucial P2? What about HDD as temp dirs?

Thanks

I didnt replace my crucial p2 yet, i’m testing madmax and it seems to be faster (it takes close to half the time to do plot phases).
Anyway checking with dstat, my disk total read/write is stuck at 150-250 mb/s wich is kinda low