SYNC checkpoint database


I had to put up new OS (windows) with some new hardware. Meaning i had to reinstall full node as well.
I downloaded the checkpoint database file from official site.

How to copy that file properly ? I see there has been a diference in name and at the end its .gz
Do I have to rename it as original to blockchain_v2_mainnet.sqlite and then replace ?

Thanks !


Thanks a bunch :smiley:

A very quick Google would suggest it’s a gzip file, so a compressed file, which makes sense, you just need to find a program to uncompress it, I’ll let you Google that.

1 Like

I didnt know it was a compressed file.
All good. Solved it.
Syncing proper :slight_smile:

1 Like

I’ve been struggle with this myself for few days. Chia has a YouTube video explaining how to unzip the file after downloading the torrent. However it’s not worked for me the way it’s supposed too

1 Like

Rename it too, the torrented file has a date in the name. Also I had two other issues as well: on a low spec board I had it just didn’t have the horsepower to read the 100GB database file and do the initial checkpoint/sorting/whatever the Chia client does with it. A low spec laptop I had WAS able to get it going and download the final two months, but only after sitting there for 3 hours to get settled in.

I download the torrent it shows up in downloads folder as a GZ file I do the 7zip then it never shows up as a SQLite file. What am I doing wrong?

I copied the name from file that is the original in the mainnet/db folder and renamed the extracted gz. file. Then I just replace the files and It worked great. You also have to shut down node and kill all .chia processes in task manager before changing anything.
Maybe you dont have the full name shown with all extensions, (you can switch that on) just a guess.

video explanation:

Its in the last few minutes is this thing, but it freezes when renaming and replacing files, but voice explains ok.


Thanks I tried that still doesn’t seem to work idk what I’m doing wrong

It’s an extremely massive file and it takes a lot of horsepower to unzip it… It takes loooong.
Try unizp and then come back later to see if it’s done.
Mine did it in the background and I can’t remember how long it took, but I thought it had failed as well… Until I used Linux tar with verbose option to show me what was happening. Then I realised that it’s just taking looooooooong

1 Like

Sorry to hear that.

I am no reference but maybe try to delete the app, clear all registry data and wallet and .chia folders.

Start up fresh instalation, connect to your wallet-dont forget to save your keys and 22 words before delete anything!

When start new, leave the app to connect to your wallet and start to sync, just that you see everything is ok with the ports and that mainnet file is created, then replace the file with the checkpoint file.

I really hope that you find a solution to your problem.
I have been syncing around new year from 0 it took me 17 days and then 4 months later my OS drive burned. Now I am here at april checkpoint which will also took a couple of days. :sweat_smile::sweat_smile:

1 Like

Got it today thanks for everyone’s help! Happy farming