Unable to join pool

Hi everyone , I am unable to join pool on Chia gui 1.2.11(windows). I got one mojo from faucet.chia.net. when i put all info for pool and click on create pool . it shows waiting for transaction and then it goes back to previous screen says “join a pool”.When i try to create pool again it shows “Can’t select amount higher than our spendable balance. Amount: 1, spendable: 0” In my wallet 1 mojo transaction is showing as pending since 2 days. no pool has been created as transaction still showing pending. I tried deleting db files in wallet folder ,did all steps again still the same .After all this, i bought some xch on exchange thinking that 1 mojo not enough to create pool. my transaction from exchange was successful and even chia explorer showing the XCH in that wallet but wallet address has been changed by itself and i am not able to see that amount in my wallet. do you know how to get back the old wallet address? I have old address copied in my notepad but gui wont allow me to change address manually.
Node status showing synced and wallet status keep doing syncing and not synced every few seconds (1101372- this number is not changing at all )
Please help me

Ohh, thank you for the information. Good luck!

ahahah it is cool, guys.