You're trying to run bladebit version 1 but currently version 2.0.0 is installed - Server RAM plot

I update the Chia to version 1.6.1 and after that when I try to plot by terminal(Ubuntu) shows this message:
You’re trying to run bladebit version 1 but currently version 2.0.0 is installed.

On the Chia GUI not shows the Bladebit 1.0 only 2.0.
So how I install only the bladebit 1.0? To a plot at ram?

I used that
chia plotters bladebit -r 48 -n 150 -f … -c … -d /media/…

1 Like

Ive never used it, but id guess download it and use cli.

1 Like

I will try that, but I’m not confident about that. It is for bladebit 2.0. And I try to run the bladebit 1 plot on memory.

1 Like

Scroll down the page… and you will see the link to this, and the other releases.


Thats why we need a test group before it gets released.

1 Like

Bladebit 2 incorporates bladebit 1 functionality.

You need to use bladebit ramplot command to access the v1 functionality.
More info can be found by executing bladebit ramplot -h

1 Like

Where can we see some sample strings of this in use??

I have not seen one string using the ramplot for an example.

This is where I got the latest Harold’s release.
Release v2.0.1 · Chia-Network/bladebit (

BB v2.0.0 has both Disk and RAM plotting options. For BB RAM, you use ramplot switch.

However, on Win side BB 2.0.0 looks like is not working (crashing at the end of Phase 1). On chia’s website, there is a download link to v2.0.1 that at least partially fixes that crash.

And yes, Harold stated that he basically didn’t bother to run BB on Win before releasing it as production code. And of course chia didn’t bother to run neither smoke tests nor regression tests before releasing v1.6.1, so a non-working binaries are proudly included in that release.


It seems no help is included for the ramplot command but in essence, parameters are the same just state bladebit ramplot .
Bladebit -h should give you a clue about the parameters
I use it under linux so maybe there are some differences.

It would be nice if somebody had tried it under windows and provided a string that worked, right?


Your asking a lot from developers who, apparently, abhor Windows and/or anyone with less than 512GB server memory. Why? Just why? Why do they hate MS so…? Oh, gee, I can’t imagine…wait …wait a minute…

And offering no help from the .exe when asking nicely (-h or /help or whatever) is just icing on the :poop: cake to this point. Lot of wasted time debugging others stuff. End rant…


Not really. This is the company policy that is set by management, and devs are just following what they are told to do. It is not their fault that company doesn’t have any QA people, and let any crap be committed to the main branch and call it “dev version” to see whether it sticks. Once github is calming down, they call that crap production release, and give it another version number. Basically, this is Elbonian model what they do.

My problem with devs (or rather Harold to be more specific) is that even though they have reports by several people about crashes, they still don’t bother to make just one test run to see how it works. Instead of that continuing to ask for more info. Although, this point can also be argued, as any non-Elbonian company has support people that verify end-user reports before hitting devs. So, basically back to management - fish stinks from the head.


For those seeking the correct commandline for ramplotting :
bladebit -t <nr of threads> -n <nr of plots> -f <farmer key> -c <pool contract address> ramplot destdir

1 Like

Thank you sir will give it a try.

It persist

chia plotters bladebit -r 47 -n 150 -f a5b26d453d614a31b92cd8bc22ed6ffa8f5a7d -c xch1jqm079q09uwhvsl8pz5d96c2tek7 -d /media/ed/271C236D39BA565C
You’re trying to run bladebit version 1 but currently version 2.0.0 is installed

chia plotters bladebit -r 47 -n 150 -f a5b26d453d614a31b96ffa8f5a7d -c xch1vm42krvgw8 ramplot -d /media/ed/271C236D39BA565C
usage: chia plotters [-h] {chiapos,madmax,bladebit,bladebit2,install,version} …
chia plotters: error: unrecognized arguments: ramplot

chia plotters bladebit -r 47 -n 150 -f a5b26d453d614a31b92cd6ffa8f5a7d -c xch1vm42krvgwxydkk8 -ramplot -d /media/ed/271C236D39BA565C
usage: chia plotters bladebit [-h] [-r THREADS] [-n COUNT] [-f FARMERKEY]
[-p POOL_KEY] [-c CONTRACT] [-i ID] [-w]
[–nonuma] [-v] -d FINALDIR
chia plotters bladebit: error: argument -r/–threads: invalid int value: ‘amplot’

I dont know what do for this works.