[11208] Failed to execute script chia

I haven’t found this error code in any topic. Can anyone help me, what is a problem here.
I thought that it because RAM, but I bought new RAM, and I have got same error.

Starting phase 3/4: Compression from tmp files into “E:\plot-k32-2021-07-20-09-30-cced34eccb391f9ca5daf763b8ff1a5883ef3e744d9f656685e4ec86312314c2.plot.2.tmp” … Tue Jul 20 12:40:10 2021
Compressing tables 1 and 2
Caught plotting error: bad allocation
Traceback (most recent call last):

  • File “D:\a\chia-blockchain\chia-blockchain\venv\Lib\site-packages\chia\cmds\chia.py”, line 83, in *
  • File “D:\a\chia-blockchain\chia-blockchain\venv\Lib\site-packages\chia\cmds\chia.py”, line 79, in main*
  • File “click\core.py”, line 829, in call*
  • File “click\core.py”, line 782, in main*
  • File “click\core.py”, line 1259, in invoke*
  • File “click\core.py”, line 1259, in invoke*
  • File “click\core.py”, line 1066, in invoke*
  • File “click\core.py”, line 610, in invoke*
  • File “click\decorators.py”, line 21, in new_func*
  • File “chia\cmds\plots.py”, line 135, in create_cmd*
  • File “chia\plotting\create_plots.py”, line 168, in create_plots*
    RuntimeError: bad allocation
    [11208] Failed to execute script chia


The problem is, its broken. You broke it. Mystery solved.

An allocation error, interesting… the plot thickens…get it? The plot thickens? :grin:

Oh yeah, its really broken.

Soooo, a few questions if you wouldn’t mind…

  • What program are you running? Stock chia plot create?
  • What was the specific command used to start this program?
  • Have you tried reinstalling Chia?
  • Are you sure you installed it correctly?
  • Was it working before, never worked, or suddenly stopped working?
  • Is it an intermittent problem or does it happen everytime the program runs?
  • Info about temp drives please. Ramdisk? Nvme? SSD? HDD? Floppy Disk? Mini Disc?

Thank you.

I use Chia GUI for plotting. I have 2 PC’s for ploting, and at other PC I used SWAR script and it worked very well. On this PC, in the past I couldn’t plot, every plot gave Bad allocation error. I have read that it happen because of RAM, I changed RAM, but it doesn’t work.

It crashed when I would start second plot in parallel.

I uninstalled Chia once, and install it again, but I am not sure that I did it well. I did it from Control panel only. What mean ‘‘installed it correctly’’. I have ran installation file and that’s it :slight_smile:

In the beginning, it worked, but sometimes some plot has been crashed. After few days, it happens with every plot in parallel. I tried to use MadMax script, and it finished 2 tables in first phase and after that it stopped and was freeze. It happen every time everytime the program runs

I use
AMD Ryzen 7 3700X 8-Core Processor 3.59 GHz
16.0 GB RAM
Samsung SSD 980 1TB 1000.2 GB NvME for plotting
WD Elements external HDD 12 TB for storage

I have adapter PCiE16 to NvME, I thought that there is a problem, and I changed it, but problem has been continued.

Thanks for help.

Thanks for the info.

Could you tell me/show me the settings you’re using in the GUI please.

I usually use default settings, just add directories and start.

I tried to use more RAM (5650 or 6780 RAM, 4 cores, 128 or 64 buckets) … I’ll send SS if you need, but I can do it late.



What I am looking for is the ram settings, and how many parallel plots you’re running.

Just trying to rule out oversubscribed ram. No rush.

I wrote, I usually use that settings. It is default settings. A tried with 2 plots in parallel, delay 180 minutes.


I can’t see anything particularly wrong. From my brief googling it says bad allocation errors usually happen because you have either:

  • Run out of memory.
  • Running too many jobs in parallel.
  • Assigned too much memory to each plot - default 3390.
  • Accidentally turned off Windows page file.
  • Bad memory.

From the looks of it, this error should not be occurring. You have plenty of RAM to be running two plots in parallel at 3390MB per plot (In fact, this machine should be able to run 4 plots in parallel, no problem).

After reading the answers you have given me, then my last suggestion would be to look at the windows paging file.

Another alternative is to try running the software in Linux, if error is still happening there, then its a hardware issue.

Good luck.

1 Like

Here’s the experience I’ve had with my daily Ryzen 3600 PC Win10Pro, somewhat similar to yours. Perhaps the suggestions will help. I was originally plotting on a TR Pro 3955wx 128GB memory, lots of NVMEs etc., but when I filled the drives I had at the time pretty much, I switched it all back to my Ryzen desktop to finish plotting and farm together, to save $$ & energy and all that. It’s my regular PC too, so it does double duty now. I’ve been experimenting for a few weeks and have some opinions and thoughts using it. It’s like a challenge to try to squeeze out the most plotting from my old Ryzen.

Let me cut to the chase and give you a quick summary re: your issues IMHO and their fix.

You don’t have enough memory. I had 16Gb, had to upgrade to 32GB. Your result will vary a bit, but I’m at
~8GB memory after boot. So w/16Gb only 8GB left for chia. Not good, allocation errors and all that, not enough memory. Chia seems to be weirdly sensitive to Windows virtual memory doesn’t seem to work well w/chi, that is, it acts strange and does these things. You need more. 32Gb works with caveats mentioned below, but 64GB would be a sweet spot size vs $$.

With 32GBs, I’ve tried many combos of parameters using the chia GUI. Certain parameters seem to work (well) and others, not so much, strangely. Again w/32Gb, you’re going to start 3 separate queues of some number of plots, spaced 2 hrs apart. So you start a queue, wait 2 hrs, start 2nd, wait 2 hrs, start the 3rd queue. Two hrs is right to finish Phase 1 (and a bit extra) before starting the next queue. Do maybe 10 plots/queue and you’ll get 30 plots in a couple days or so. With that spacing I get 10-11 plots a day & farming, while I sit and play on my PC as I like to.

Parameters: for 64 buckets use 7168 memory, 6 threads; for 128 buckets 3840 memory 4 threads. Both work well and do about the same, although the 64 bucket one works a tad better, saves some ssd writing.

Good luck!

ps. Put Win swap file to system default. If you change to using more memory/plot, you’ll need to start playing with that, just don’t and it will work.