Advice and trouble shooting

Good day ladies and gents. Long time lurker, first time poster. I generally try to do my own troubleshooting, but I have reached an impass that I can’t work around nor figure out. I’m a small farmer (250tb), but grow as money allows.
My issue is I am trying to reach below 10 minute plot times and no matter what I do I just simply can’t. Some issues I do know about. (Using windows, using the gui etc.)
System= z840
Cpu =2x e5-2699v4
Ram= 512 GB 2400mhz ddr4 quad channel
Gpu= Asus tuf 3060ti in a pci-e 3 x16 slot @ x16 cpu0, gpu @2100 mhz, gddr6 @1750
OS=Windows 10
Plotter= gui bladebit Cuda at present.

I use primocache as a buffer to off load writing to disk so plotter can move to next plot. At first I just gave it 16 gig of ram as an l1 cache and the remainder of the plot went to a u.2 in a pcie adapter. Then changed it to a 64 gig ram cache that writes every 10 seconds. As we all know the hard drive is the slowest part. It always finishes before the next big write of the next plot (making c7s).

So I read in a post that NUMA can make things more difficult when plotting. Observed pci-e through put before and after deactivating NUMA in bios. I did see alot more bandwidth with NUMA off. 26,000 mbs a second is the peak I saw using hardware monitor. Cpus are turboing etc. I am out of ideas and am getting 12-13 minuge plots. Pretty slow IMHO. Is it all software or am I missing something in the hardware? Thanks.

I think the problem is likely the write to disk, not sure why you are using Primocache either, with 512GB of ram you could make a 256GB ram drive.

How fast is the U2 drive?

Basic aim is to have the gpu, cpu, memory all on the same side

Sorry , thought I made it clear. I use it as a buffer only for writing to disk . Plotter writes to ram only essentially . SO plotter sees plot written (to ram) and goes to the next plot instead writing to a disk at best speed 300 Mbs and holding up the whole show . Yes the cuda plotter has its 256mb necessary for ram only operation. Primocache’s only function is buffering disk write.

Thanks I may have to dig into this more. I left it deactivated I may have to assign affinity to only the gpu cpu which is cpu zero. Right now I just let the plotter use whatever thread it wants on whatever cpu it wants . I may be shooting myself in the foot doing so .

I switched from Windows to Linux Mint for plotting, and it was twice as fast, my 3080 went from around 6 minutes to around 3 minutes. So it could just be that, but my P4 was taking around 10 minutes in Windows, and I’m sure 3060TI is way more powerful than a P4. The P4 was around 6 to 7 minutes in Linux.

1 Like

Thank you very much ! I was afraid it was Windows . Off to Linux I go .

yes Linux’s Numa handling is much better in my experience.

The other issue is that Bladebit is just really not optimized at all for Windows.

With your setup on Linux, you should be getting sub 3 minute plots

1 Like

Yep 2 minute 45 second plot time on Ubuntu . GPU now gets full usage and the pci-e bus is getting way more throughput . Now the issue is moving the plot to the hard drive . Gotta find a linux-noob easy script so I can write to a u.2 and move from there to my sata drives.

It isnt’working on the newest version of linux I think, but it was still working on my recent Mint install
there’s some others floating around as well

1 Like

If the hard drive is on a Windows system then you can use my plot mover. I share the drive on the Linux plotter, then move plots from the Windows farmer. It’s a nice simple GUI, no CMD line scripts involved, ideal if like me you struggle with Linux.

1 Like

Having issues with Plow. I keep getting this error . Help? Tried any way I could think of at writing the source path but nothing seems to work . I suspect the Destination would have the same error , but I never get that far.

/dev/nvme is a disk partion, you need to use the folder path where that partition is mounted to

1 Like

%Thanks for the reply man . Yeah I figured that out this morning (I work nights so Im a zombie). But after I got that figured out and used the proper path , It said syntax error at the end of my path media/gm/Chia Temp. Didn’t get a screen shot as I am on my daily driver.

might just need a trailing slash
(also I always avoid folder names with spaces in them, just to be sure)

media/gm/Chia Temp/

IIRC, Plow is very sensitive about that imput, I will check how I have it set when I’m home again

1 Like

Thank you for the reply . Well I figured out that path and it accepts it . It begins and tells me it is plowing all 3 of my hard drives. It then flips out about rsync . Giving me rsync errors (something about 23) for each individual hard drive.
I see others just throwing drive paths in this thing and running and its been a fight for every inch of ground for me LOL.

You should use ubuntu for plotting, its faster than windows. I can make plots within 6 minutes on a gtx 1070 with 712gb of ram. And this machine runs as virtual machine on my server.

1 Like

Yes i switched to Ubuntu and you are correct. Plot creation is under 3 minutes. But now I can’t get them out of the way. So bladebit is feeding a sata drive instead a ssd. So 10 minutes to move a plot. Ubuntu is ram caching the whole thing which is slowing the whole system down. Blade bit writing the file drom ram 150 mb/s. Writing to u.2 and then sata drive in the sas/sata drawers of my pc 600 mb/s.
Still fighting with plow to see if it will work on the newest Ubuntu. No luck so far and I’m still plugging along at cpu speeds.

1 Like

Are you moving them to Windows harvesters?

If so I use this to share the drive across the network.

Then I use my plot mover (link a few posts above) to move the plots.

1 Like

My Sata drives are limiting aswell I can get only 300MB write speed, so I have script that pauses my plotter when my SSD temp drives got to full, until he shuffled all temp plots to their target dest on the HDD.