Chia app hangs up with message 'Connecting to Wallet...'

Chia app stopped working after my Windows 10 PC was restarted automatically after an update. Now when I start the app it stucks on ‘Connecting to Wallet…’ , see the screenshot

app version is 1.1.7:

see https://developernote.com/wp-content/uploads/2021/06/image-7.png

I did a google search, found some related topics and tried to remove

C:\Users\D-Ef.chia\mainnet\db
C:\Users\D-Ef.chia\mainnet\wallet\db
.C:\Users\D-Ef\AppData\Local\chia-blockchain
“C:\Users\D-Ef\AppData\Roaming\Chia Blockchain”

but with no success.

Is there some solution (without loosing the plots)?

You have to turn all Chia processes off and delete your wallet db file. This is your wallet sync file, not your wallet.

mariano54 commented on May 4

  1. Shut down your wallet and node
  2. Delete your wallet db files: located at ~/.chia/mainnet/wallet/db. This will require syncing up your wallet, but not your node.
  3. Make sure you have upgraded to the latest version
  4. Start the application and wait for the wallet to sync up

So you shut down Chia and any Chia processes and delete (or rename to .old if you are concerned) your wallet db. Download and upgrade Chia to 1.1.7 (if you have not already done so). It’s not required, but I would re-start my computer first, and then re-start Chia.

Your wallet sync will start at zero again, but will sync up in a normal time. Your full node sync is unaffected by deleting the wallet db and re-starting your wallet sync.

I had the same problem and did this successfully and without problem when I upgraded Chia to 1.1.7

1 Like

Looks like it started to sync. Probably restarting PC helped.

2 Likes

It also depends on the speed of the system. I have a wallet on a really slow system (2GB of RAM) and when I start it, it will sit at that loading screen for like 10 minutes. I does come up. But it takes a long time.

1 Like