Gigahorse Compressed GPU Plot Client Released! Start Plotting Now!

Hi, it works for me with 64GB, I put 128GB of RAM and it says this (Ubuntu 20.04):
./cuda_plot_k32 -n 2 -C 8 -t /media/tom/220_alt/ -2 /media/tom/220_new/ -c … -f …
Chia k32 next-gen CUDA plotter - c892fce
Plot Format: mmx-v2.4
Network Port: 8444 [chia]
No. GPUs: 1
No. Streams: 4
Final Destination: /media/tom/220_alt/
Shared Memory limit: unlimited
Number of Plots: 2
Initialization took 0.217 sec
Crafting plot 1 out of 2 (2023/03/14 18:38:01)
Process ID: 3224

Working Directory: /media/tom/220_alt/
Working Directory 2: /media/tom/220_new/
Compression Level: C8 (xbits = 8, final table = 4)
Plot Name: plot-k32-c8-2023-03-14-18-38-76ec2cb95be607309f5c48c9bc6f9570cfba2a016f838ff2c8d501c4f4b7cc77
Created disk buffer /media/tom/220_new/cuda_plot_tmp2_1678815481513596.tmp
[P1] Setup took 0.601 sec
[P1] Table 1 took 17.814 sec, 4294967296 entries, 16789725 max, 66675 tmp, 0 GB/s up, 1.90862 GB/s down
terminate called after throwing an instance of ‘std::runtime_error’
what(): out of memory
Aborted (core dumped)

The RAM is occupied at about 80GB (I tried it with 160GB RAM as well) Thanks.
(e5-2630 V3, X99, GTX 1060 6GB)

hello guys,
if same question already answered i am sorry. i did not see.
i have i7 8k
128 gb ram
on windows

i am plotting with disk cuda around 44 mins. no compressing.
if i start plotting with gigahorse compressing 0 am i saw same minute per plot file ? any idea ?

Looks like your running out of VRAM. You might try adjusting streams from 4 to 3.

I don’t believe compression 0 is an option for GPU or CPU, has to be 1-9 when using Gigahorse.

Try to turn off swap memory

swapoff -a

it seems to work and even already on Windows, just “-S 3” and I’m struggling for a week …

@madMAx43v3r I noticed that you quit compiling Gigahorse for the aarch64 (RPi4). I used this to farm uncompressed pool plots. Am I ok to just continue using the old build of Gigahorse-farmer? Other than my 30 or 40 TB on my RPi4, the rest of my harvesters compressed and have GPUs. Just wondering what I should do about these USB drives that are linked to my RPi4?

Is the Gigahorse cuda_plotter on my computer normal or weird?
The first plot takes about 13 minutes, but each of the subsequent plots takes about 21 minutes, although I already define 2 destination by “-d Y: -d Z:”. The 8 minutes is caused by the copy process?

I put it on two NVMe (-t and -2) processes, plotting takes place on -2 and from -t (-t can be SSD) it is copied easily.

Thank you for the tip, I’ll try it.

The latest versions are not relevant for RPi, they only added OpenCL farming support, which is not supported on RPi.


Hi max i have installed gigahorse node and plotting c7 and c8 plots. However when i check farm summary only my local plota both og nft uncompressed plots and compressed plots is seen by gigahorse. My remotte harvester all uncompressed nft plots are not detected.

When i use the original chia client gui , the remote harvester shows up. What could be the problem? Thanks

Have you installed the gigahorse software on the harvesters as well?

Yes, need to use Gigahorse for remote harvesters as well.

1 Like

Thank you both for the responses. I installed gigahorse on the harvester and run the harvester from there and it worked :slight_smile:

1 Like

Now when running c8 plots it just stopped at P1 and stuck from there. Rebooted my windows machine and still got the same. Tried c7 plots and still no luck. Powershell is stuck. I will get some screen shots when i get the chance.

Probably not enough free RAM

I have a 128gb or ram and using -2 and also -M 64 on the cmd line

Crashes when making c5,c6,c7 and c8 plots and it works on c4 plots but after 5 plots it crashes again…

What type of video card are you using?

Im using a 3070 msi. It was odd because it was working fine for c8 plots then after like 20 plots it crashed even after reboot of computer.