Harvester not sending partials to pools, Harvestor '127.0.0.1/######## did not respond

as title shown getting error.

only 1 harvestor, my machine has been running for months with occasion on/off to reinstall newer version of chia GUI. just within last week, it stop sending partials. at start, a restarting computer would fix it for a few hours then stop sending partial again.

I have been asking around and people say to contact pool for support but imo this isn’t a pool problem, its the GUI issue.

error log shows:
ERROR Harvester ‘127.0.0.1/########## did not respond’ (version mismatch or time out 90s)
or
WARNING peer surpassed rate limit 127.0.0.1, message: new) sinage_point_harvester, port 8447 but not disconnecting

havent touch it for months and this start to happen, people told me to try different things and I’ve spent last 5 days doing everything including:

  • port forwarding (was never needed prior to this, nor was anything changed in router)
  • downgrade to different chia version 1.2.9
  • restore to previous image with stable 1.2.11
  • delete entire db and wallet db, resync everything

what bugs me the most is the image backup was when it was still working from ~2-3 weeks ago, but now restoring doesn’t even help suggesting this isn’t from my computer end. either CHIA network, or the pool.

I have done all above and NOTHING WORKS. so pls HELP, give me a definite answer on what is causing these issue and how the hell can I fix this going forward. tired of wasting days trying solutions that dont work.

they talk about how good the technology is compare to other crypto but imo its pretty much junk, especially when you don’t have it working theres literally zero support and no solution from the official chia team.

I’m assuming your on Windows?
Has your system crashed / restarted / closed unexpectedly?

I’d try running these as it certainly can’t hurt and could help.

I had that error, but it fixed itself, or something I did fixed it.

https://support.microsoft.com/en-us/topic/use-the-system-file-checker-tool-to-repair-missing-or-corrupted-system-files-79aa86cb-ca52-166a-92a3-966e85d4094e

If only it were so simple.

thanks for responding.

not of recent, and if theres any crash it would have been fixed with the restoral image that was stable which rules out the crash.

Unfortunately, no one ( I can say with a high probability) can answer this for you with a one fix solution, it will take trying many things as I’m sure you’ve become aware.

If you’ll not even try those steps, I’m just gonna bow out and wish you luck.

All the best.

1 Like

Good morning, can you be sure that your backup image doesn’t have a small bug?

c:\windows\systen32>sfc /scannow

It’s just a start to help find your issue. Like Bones said it will take a little time.

It was scannow and dism I was reccomending.
If the image worked before and now doesn’t I’d assume a poss win error so worth running

I think the OP has tried many things and had enough.

I think this conclusion stops them even attempting my idea, but I think that assumption is wrong, and it is as you said, possibly a issue with the image.

well already dumped 3 days into this stupid thing, another hr doesnt hurt.

another one is people saying: “you need to fix 127.0.0.1 on your end”. like whatever does that even mean or where do I even begin trying to fix it.

That’s your internal ip.
I would agree if you were running a main node, and had separate harvesters set up, and it was one of those separate harvesters complaining, but thats not the case as I read it.

Those things we mentioned are pretty fast, might not help but worth a go

That error may be a secondary one, so I would shut down your chia, remove all logs from your logs folder, start chia, and then run “findstr ERROR debug.log” also run it with harvester and then farmer instead of ERROR. Maybe there will be some early warning or error generated.

By the way, when you dropped down to v1.2.9, did you still have the same error?

(127.0.0.1) is your local host IP

where do I run this “findstr ERROR debug.log”? command line? under which directory path do I type this?

when I drop down to 1.2.9, it give similar error. only 1.2.11 gives error of time out 90s, every other version give similar error but jsut say not latest version.

In command prompt run the first two commands. It should show you 8 files (debug.log.X). If you see those files, and one of them is just debug.log, run one of those findstr commands at a time. Hopefully the ERROR output will have some harvester / farmer related errors. Then those two other findstr may reveal more info related to those errors.

But, remote the old logs (del debug.log*, or do it in the explorer, if you don’t feel comfortable about command prompt), before starting chia, and running those commands below (no need to look at old junk).

Paste those errors here, so maybe it will be something easy to find.

cd %userprofile%\.chia\mainnet\log
dir
findstr ERROR debug.log
findstr harvester debug.log
findstr farmer debug.log

well I see what you are trying to do, finding ERROR from the debug log. which I already use notepad++ to open them and find all ERROR lines.

the only ERROR is ERROR Harvester ‘127.0.0.1/########## did not respond’ (version mismatch or time out 90s), while the 2nd one is WARNING.

there are bunch of INFO which imo should be WARNING or ERROR because clearly they are saying things like:
INFO Cannot connect to host 127.0.0.1:94444 ssl: (the remote computer refused the network connection). and GUI can’t even sync.

so clearly only searching by ERROR is pointless, which I have checked already.

currently trying the DB from this link https://www.reddit.com/r/chia/comments/pz7tmq/updated_to_128_and_now_cannot_connect_to_host/ and then rebuild the wallet and see if that does anything.

I’ve only just woke, so forgive any stupidity on my part.
Shouldn’t that be 9444 not 94444, is not that the error, wrong port config.

I dont think ports nos should be so high.

  • Well-known ports range from 0 through 1023.
  • Registered ports are 1024 to 49151.
  • Dynamic ports (also called private ports) are 49152 to 65535.

its 8444, typo it is

:slight_smile: Those ports cannot be that high. They can go only up to 64K (max 16 bit number). Good catch!

This is why I asked you to also run findstr for harvester/farmer. Most of the junk in debug.log is related to full node going nuts. There is not that much output from either harvester or farmer. So, when you run those extra findstr searches, maybe those problems will be easier to find. That is also the reason I asked you to remove the old logs, so there will be not that much some old stuff in those results.

Saying that, I would also run findstr against wallet.

This one is maybe telling. 8444 port is open by full node. This implies that something else (your wallet / farmer / harvester) couldn’t connect to it. So, seeing the full line will show which process is struggling.

However, it may point to your local firewalls blocking those ports. When you installed chia, maybe somehow you didn’t click “Allow” button that firewall should be producing. I would bet on this one right now.

Then don’t manually write those things, just copy the exact text from your logs.

found the issue. maybe someone else getting similar problem dont have to waste 5 days like me.

my system is 1 harvester also farmer, holds some storage, while 2-3 other system are connected to the farmer via ethernet with network drive (folder share). because of issue running out of drive letter under windows, I raid0 hard drives in set of two, I have got plotters enough to be able to fill up 22 or 24TB worth in a day to day and half.

not sure how window/disk management work, but one array gone bad and disk management shows health risk of 1 drive having problem in the array. however the windows explorer still shows ALL of the plot file and name for w/e reason.

property of the raid array/fold ershows 3TB out of like 20TB and im guessing chia doesn’t know wtf to do with it. so instead it errors out while log simply says host is not responding and times out and entire GUI locks up. very poorly designed imo.

deleting the array and replot fixed it, as long as dont add broken array it’ll farm just fine. everything else including resync/wallet sync, disk scan on the OS drive, none helped which make sense, they weren’t broken to begin with.

I have other system setup remotely so unless plots dont disappear under GUI I never bother to look, which GUI doesnt remove the plots from the broken array for w/e reason. only caught it after I disconnect each system at a time.