How do I recover plotnft pool info of NFT plots?

Chia crashed so I uninstalled and reinstall 1.2.3, All the pool info ties to nft plots are gone both in the gui and in config.yaml. How do I recover them back?

Nft info is in the blockchain. Wait for full sync.

fully synced but still the info on nft pool is empty

1 Like

You used the same key (mnemonic) after re-install?

Wallet sync also?

Yes I’m using the same key. Both full node and wallet are fully synced (657,525)

1 Like

I guess this is the cause of it all, removed addresses for security reason

Wallet height: 657749
Sync status: Synced
Wallet id 2:
Current state: FARMING_TO_POOL
Current state from block height: 653495
Launcher ID:
Target address (not for plotting):
Number of plots: 0
Owner public key:
Pool contract address (use ONLY for plotting - do not send money to this address):
Current pool URL: https://chiapp.hpool.com
Relative lock height: 100 blocks
Exception from ‘wallet’ <bytes32: >
Unclosed client session
client_session: <aiohttp.client.ClientSession object at 0x000001A3D08E3100>
Unclosed connector
connections: [’[(<aiohttp.client_proto.ResponseHandler object at 0x000001A3D0963E20>, 3855.562)]’]
connector: <aiohttp.connector.TCPConnector object at 0x000001A3D08E3070>

1 Like

Close Chia app, delete de wallet DB and resync. I’ve heard this often solves the problem where the NFT don;t show up after install

well got that fixed by pasting pool addresses part from a backed up config file

2 Likes

Could you please print this part of the config file? I have the same issue, without a backup to look up.
Thanks in advance.
Update: even fully sinced it didn’t appear. Then I decided to plot a new one and check how it would be registered on config, but when I plot a new NFT for same pool the old one reappeared together with the new.

it differs for each individual key

1 Like

Hi Voodoo, does this definitely work? Thats a lot of GB to sync. I have the missing plot NFT after a reinstall, where I went for a blank config as I had some other issues, and now my plot NFT is missing. Should I resync the wallet DB from scratch or try adding the pool contract address in config?

You should resync the blockchain (and be sure you have enough free space for it, it’s growing).

Okay, so I didn’t fancy the blockchain reinstall. Sorry but the advice above was suboptimal at best.

Here is how to do it:
Shutdown Chia. Using a backup config.yaml - please backup regularly, whenever you take your farmer offline, back it up, keep a few versions going back.
In the file there is a pool section it looks like this:

> min_mainnet_k_size: 32
network_overrides: *id002
outbound_rate_limit_percent: 30
ping_interval: 120
pool:
  logging: *id001
  network_overrides: *id002
  pool_list:
  - authentication_public_key: '0xb887a2201b50adabbd2ad336bcbf9c881b1290568b209c43ae2***************15ac95f73bdedfddd508b34b6178a5e07'
    launcher_id: '0x55495b4898bfa16b454f8b766aee084be459a1a***************b8e01ac9c27c7e1'
    owner_public_key: '0x90093eda684df2894795127330a4fef5c560************************e13a418434bd6f0a3864a1edda757103c7872cacd0b'
    p2_singleton_puzzle_hash: '0x307ffeb159c52485d646ce210f6f***************************ec32a430af459fd9f58c'
    payout_instructions: 2e99f8538e11fca**********************e87aad78b6ed5c77fb33075dff5456fd83c9
    pool_url: https://pool.findchia.com
    target_puzzle_hash: '0xed6be661ca2dc45deb********************3a18109feffcda2c8fe0e226de9511659'
  selected_network: mainnet
  xch_target_address: xch196vls5uwz872xffcm9was**************************8thl4g4has0yscnn4pw
private_ssl_ca:
  crt: config/ssl/ca/private_ca.crt
  key: config/ssl/ca/private_ca.key
selected_network: mainnet
self_hostname: localhost
timelord:
  fast_algorithm: false

All you need to do is to copy from
pool:
to the line above
private_ssl_ca:

Into your current config.yaml, save and restart chia and your NFT and pooling comes back my NFT is visible on the pool tab.

Also, if like me you reinstalled from fresh (but using backed up DB and wallet files to save yourself 30GB of sync) make sure if you were sending rewards from OG, solo or OP farming to a cold wallet to restore your cold wallet address in “manage farming rewards” on farm tab, and payout address in pool tab.

The advice is not to reinstall, the advice is to resync.

Your NFTs are stored on the blockchain.

I was fully synced and they were not there. If the solution were that simple, I would not have been asking for it, given that’s the first thing I tried. Thanks for the effort but unless you know the answer it is better not to take a guess.

Well if your install is corrupted, just copy the blockchain file, so when you reinstall, the regeneration of databases is quick.

It wasn’t corrupted. I copied my perfectly working DB and wallet. But I was having problems with my plot directories, I figured I had a few characters incorrect in the config.yaml (and it is very sensitive to this) so I decided to do a fresh install but with DB/wallet preserved. I did this, manually added my key, created a passphrase, manually added the plot directories, then waited for full sync. Which I had.

However, the plot NFT wasn’t there even with full sync. So I am not sure it just pops back up.

In fact, I am very confident that it does not, certainly not with the way I did it. However, copying the relevant section from the backed up config.yaml worked perfectly.

Thanks for trying but it was not the right way to go about it.

Advice to others, make sure you have config.yaml backup if you do a full reinstall, but are retaining some elements from your old install.

UPDATE - Working normally now and pool receiving partials confirmed.
I think with a fresh install, key added and a sync from an empty DB to synced the NFT/s should have come back, if they haven’t because you went a different route try this approach instead.

1 Like

Good you have it working now.

Yes if you have a backup of your config files you can just copy paste the pool info to your new config.

I didn’t have that, so i resynced.
To be clear I just resynced the wallet DB not the blockchain DB. Wallet db is much smaller so easier to resync.
At the time I was also fully synced no errors, but also no nft’s showing up.
Deleted the wallet db and after it was synced again all the nft’s where there.

I think the problem is that when you copy the wallet db from an old install, you miss the event where the info get’s written to the config. When you let the wallet resync, the block where you created the nft will come by again and the info gets written into the config.

Dont know if newer chia versions already fixed this or not