Loading keyring status stuck

Hi, please help me. after june Windows updates i cant run chia farming. Loading keyring status stuck… Reload/Force reload doesnt helped, many restart pc doesnt helped, uniinstall/complete delete all Chia folder/files doesnt helped… IDK what i can more…´
Edit: tryed 1.3.5 was working before June Windows updates…, 1.3.4, dev 1.3.6 on W11 with last June updates, 1,5 TB space left… debug.log is empty for these last not working days… on virtual pc worked, on other pc worked clean instal…

Maybe you can start with which Win version you have, which chia version you have, how much disk space you have left, check ERROR level lines in your debug.log file, some screenshots.

If in trouble, stay away from dev (1.3.6), 1.3.4 was also a bit buggy. Just use 1.3.5.

Move your ~/.chia_keys folder out of the way, as that will be forcing chia to generate a new one. Eventually, kill your wallet db.

Maybe also try CLI ‘chia start farmer’, maybe that will come back with some more reasonable errors.

Edited edited edited.)

yeah problem is uninstalling Chia…well doesn’t uninstall it, leaves a lot behind.

Like @Jacek said. Close down Chia and move the key files somewhere else. It should make new ones.
deleting wallet db also helps to fix an unknown amount of errors.

If all else fails, re-install windows (Wndows’ most important feature :sweat_smile:) If it comes to that make sure you keep a copy of the database on another drive so you don’t have to re-sync from 0.

i deleted C:\Users%username%\AppData\Roaming\Chia Blockchain+C:\Users%username%.chia+C:\Users%username%.chia_keys+reg keys and nothind. i cant reinstal Windows. why? ist absolutly incomprehensibly. i need fix just third application. in debug.log isnt error…

You can set the log level to INFO or DEBUG in the config maybe that will give some more information.

But honestly you seem to have deleted previous install quite thoroughly, so there might be a not Chia related problem.

I mean Windows sometimes just breaks itsself in my experience.
Not being able to reinstall/reset is quite a problem.

Also you can ask on Chia’s keybase. Lot’s of devs there. Someone might have an answer there

1 Like

Yeah, I love that “no smoke” joke - No Smoke Joke :slight_smile:

1 Like

Thank you for the answer, but problem still perssist. Windows working without self problem and i cant reinstal os only for this now.(

If it is a possible windows issue, maybe worth running scannow and dism to fix any windows issues.

hi, thank you for reply. i tryed both. all is ok.

1 Like

Please, help me someone.(

Have you tried and rename the db folders and install 1.4.0? If you have enough space on your C:\ drive. You wasted 28 days so far 3 to 4 days to sync won’t kill you for sure.

hi, yes i tried delete all Chia folders and instal now 1.4.0 too.

You deleted all the folders and when you installed 1.4.0 did it ask for your 24 word phrase? And what is it doing now? Is it syncing?

no man, i am stuck on Loading keyring status as i writed.

Just a question, how many PC do you have to work with and what are the specs. With all this wasted time, I would take a PC put Windows 10 pro and install fresh, install chia 1.4.0 fresh add my keys and grab some coffee and be done. Its like using a butter knife as a screwdriver because we don’t want to go to the garage and get the right tool. Nowhere in this thread have you stated what type of PC, CPU memory and disk space you have to work with. That would be very helpful to others as well, reading this.

i cant reinstal my main pc. many many tweaks, works and private things… CPU AMD Ryzen 3600, 32 GB, many free fast disk space. all was fine. one day, maybe after june Win 11 update stop working-stuck on Loading keyring status. tryed all Chia folder delete… all other is working fine…

Sorry don’t have an answer, I have not tried windows 11 again after it came out many months ago, too much stuff not working correctly as you can see. Too bad you don’t have another machine to tinker, After Windows 11 updated you got hosed.

update: “one of ten” start/restart pc Chia will start normal. i dont know what this is…

I just had this, after doing some Windows 10 updates, luckily after I rebooted it, Chia 1.8.0 sprang back to life.

Good job, as I need to go and put the barbecue on.

1 Like