Make sure blockchain database is on a fast drive?

I noticed this "It took 46.67s to apply 310 (2888 bytes) additions and 712 (6224 bytes) removals to the coin store. Make sure blockchain database is on a fast drive" in my full node log. This is unbelievable, since my chia db store on an external, USB3.0, SSD, and disk performance tests return at leats 50MB/s write. Is this a real problem? Can SQLite3 be this slow?

Getting a similar response in my logs - any fix for this. Have been been unable to farm for days now.

Everything that is not used right can be slow.

50MBps is rather low. Drop your peer count to 10-20, that may give your db some breathing room. After that, start working on getting your db on directly connected SSD, or better on an NVMe. I assume, you are on RPi, if that is the case, get another one, and dedicate one to be a full node, and the other a harvester. Another option is to join Flex pool, and use their client.


Thanks Jacek,

I found your post yesterday on the topic tried it. Dropped my peer count down from 80 down to 30 and it seems to be working - it has just finished syncing and seems to be staying up. ie not dropping nodes down to 0 again.

Running on 3770k cpu, 8MB ram

I would really not hesitate to drop that peer count to 10, if needed. Overall, it kind of hurts the network to run that low (the whole chia network, not your connections), but the choice is either having a node that runs or not.

As far as your CPU, let’s say that it is not the top of the line, but it should be sufficient to run Chia node. Although, you are crippling it by having only 8GB RAM. If you can, I would get 32 GB RAM upgrade. The second thing is what is your db sitting on? Is that a HD, SSD or NVMe? I assume, you don’t have M.2 slot, so I would get a PCIe/NVMe card ($10), and get 250/500GB samsung 970 evo+ NVMe, if only to host your db (you can leave your OS on whatever you have now).

If you are using USB to SSD external adapter make sure this device has his own powered suply. I’ve had problems using one USB to SSD with no powered (only the own usb) and dissapear when switched to a powered one.

Also make sure you connect It to the usb 3.0 ports.


1 Like

Well that didn’t last long. Peers dropping to 0 again. I will drop the peer count to 10 and see how that goes.
Yeah, my hardware is old, no M.2 and NVMe, all running on HDD. I need a new board with more slots, for sure. This issue started after the duststorm.

So we have gone from Chia can run from old HDD’s and or a Rpi to now moving to NVMe’s.
Hopefully when the new update CAT comes out it won’t require a dozen threadrippers to keep it going :grin:

1 Like

I kinda hate to agree with what @Jacek has said for a while now, but shitty coding…

My node was fine for 24hrs, I checked farmr and could see nothing so checked my node, its synced but not farming,
Restarted and now none of my plots are visible ffs.

I’ve stood up for chia for a long time, but this truly is a clusterfuck.

Good luck with your issues.


I can’t seem to remove my plot folders so thought delete .yaml and start over, and low and behold I can see .yaml, but my pc says it doesn’t exist so I can’t delete it…

Maybe you can try command line in an elevated mode? You can try to run “attrib -r -s -h *” on config folder. That will remove read-only/system/hidden attributes from config.yaml (if somehow those got there somehow). Also, reboot may help, and trying to make those changes before you start chia. The worst case, you may need to try to take over the ownership of that folder.

Although, if you can edit that file, I would manually remove those folders from config.yaml. I do this all the time, and works like a charm, but I was never (yet) blocked as you are right now.

Again, I am so happy with v1.2.6, and am shitting my pants reading what people go through when upgrading from one crap version to another. I would really love to upgrade, but as I said, my version (and I think v1.2.7) are more on a stable side.

1 Like

Stick with it and don’t upgrade…
Eventually the yaml disappeared, I’ve readded most drives, working on last 5 that are being stubborn.

I ended up creating a new .yaml just so I could delete it

Lol, I’ve nvr seen this before, whole screen is white, nothing showing but my cursor…

1 Like

Old is just a perception. It is easy to assume that H/W is old, but it is usually hard to provide data that would support that. You should be really fine with what you have. If you are still on the fence with those upgrades, then just get one Samsung 870 EVO SSD, and that will for sure help.

As I mentioned earlier, the success of Chia depends on having a stable network (plenty of nodes with plenty of peers). The big majority of that network are small farms (say from 10-100TB). Those farms are not running on Threadrippers, and looks like are right now on the border of stalling.

I would not mind to sign a petition to have Chia hire Flex pool to rewrite the code, as so far the have proven that what they do is both efficient and reliable.

Id sign that, to be fair, they certainly have competent coders…

Did you see my edit above white screen wtf is that ffs, force shut down chia with task manager and logged out , on logging in, black screen wtf

Hoping restart fixes it, don’t wanna move all back to other box but may have to.

Login out/in is not really killing all processes, as those that are in the background may still cling to life. Really, reboot should cure most of those lingering processes (unless some of those are set to start on boot, but chia is not).

Also, I think that the latest Windows updates may be kind of bad. I also see some strange behavior on boxes that don’t have Chia installed (for the past couple of weeks or so). So, maybe that is kind of a bad coincidence. I guess, we need to get the second round of dust storm now, and we can start packing.

Yep, reboot got screen back, not sure if to laugh or cry, think I’ll suck it up and have another beer lol, feckin hobbies…

All good again, for how long is anybody guess with this shite pooling really is a must.

1 Like

So another odd thing, after all that my node is passing plots up to the latest minute, but farmr says I’m not farming… I’m at a loss.

Quick fix, deleting .yaml has reset logs to warning and farmr didn’t change it back as usual.

Hey Jacek, just getting back - your fix seems to have worked, fingers crossed. 10 peers and holding for a few hours now.

Thanks for your help :+1:


Hi Jim, great that you are unblocked!

There is no magic in 10 peers. By default, one slot is taken by your farmer, and one (or more) by your harvester(s). I would think that if push comes to shove two/three slots above those internal ones should still make a node run. Although, the less connections you have, the more likely you may end up with starving nodes that will basically suffocate your node. So, just be aware, that doing that is a bit a double edge sword.

However, whatever you do, don’t try to manually knock off some nodes in hopes of getting “better performing” ones. Let the protocol figure that out.

Still, try to replace your OS drive with a good SSD (I have in my node Gigabyte SSD, and it is just crap (although perfect in all benchmarks), had to move my db to NVMe). I do believe that Samsung 870 EVO is a good one (have few of those in my “old” boxes, and those have never failed me). Also, look into getting more RAM, as with 8GB you will start having some memory trashing, and that could be another reason to slow down db access. I would really delay getting a new MB, …

1 Like

I tried to read that sentence few times, but I assumed that your “ffs” was just a typo for “wtf.” Sorry, looks like I still don’t know what that is.

Ffs = for f***s sake…

Musta been a windows issue, restart fixed it, but I’ve had that box 8 Yr and nvr seen a white screen before lol.

1 Like