Not sync for1.2.9 even after delete DB and resync

Hi, I hope anyone could help me with the issue. My chia node is stuck at syncing after electrical blackout at my home so I decided to delete my DB and everything in .chia. However, after try to sync it again it stuck at 933,121 block for some reason. I already done the 8444 port, time sync,upnp. Can anyone help?

In logs it said :

2021-10-16T11:38:37.254 full_node full_node_server        : WARNING  Trying to ban localhost for 10, but will not ban
2021-10-16T11:38:37.255 wallet chia.wallet.wallet_node    : ERROR    Error while trying to fetch from peer:Peer returned no response Traceback (most recent call last):
  File "chia\wallet\", line 555, in batch_sync_to_peak
  File "chia\wallet\", line 687, in fetch_blocks_and_validate
ValueError: Peer returned no response

2021-10-16T11:38:37.257 wallet chia.wallet.wallet_node    : ERROR    Loop exception in sync Was not able to add blocks 781222-781254. Traceback (most recent call last):
  File "chia\wallet\", line 608, in sync_job
  File "chia\wallet\", line 668, in _sync
  File "chia\wallet\", line 565, in batch_sync_to_peak
RuntimeError: Was not able to add blocks 781222-781254

When mine got stuck, I went to wallet tab top right are 3 little dots click that and delete unconfirmed transactions.
Worth a shot.

Good luck.

Not working for me but still thanks

Welcome, the only other thing I did was delete the files you already did.

You are on the latest version .9

My bad, yes you are, I’ll be home in half hr , I had a node syncing, I noticed it was showing a max no under 1 000 000 so if mines also stuck and I find a fix I’ll let you know.

Sorry , mines all synced up.

I have not seen that exact error. It looks like you dropped a peer (normal) and either failed to fetch the block or maybe got a corrupted block (not normal). After that it seems unable to add blocks. If this was exactly right, you would have stopped syncing at 781222, but that is as close as I can get from the message.

First check to make sure you actually have 1.2.9 installed.

Assuming latest version, I would hope that you just had bad luck, not a system error.

With this hope in mind, my best suggestion is to delete the blockchain and wallet db (Not sure both being deleted will help further, but it might, and takes no longer to re-sync so why not) and re-sync again.

With good luck you will get a clean blockchain build this time.

Just a guess (probably a dumb one) but do you have enough room for the db and wallet files. Some 33GB now i believe. If you’re running an linux system on say a 60GB SSD this could become an issue. Just to be sure…

1 Like

check your pc date and time ? That worked for me.

Thanks for the reply, I use 1.2.9. I did try delete db already and resync but it still stuck at block 933,121 with an error

full_node chia.full_node.full_node: ERROR sync from fork point failed err: bad encoding.

I try deleting everything include chia itself still no luck. Also, I try copy database from my second machince to this one also no luck. The only thing left I haven’t try is reinstall my window.

I have almost2 tb left in my M2 drive so I don’t think storage is an issue here. Still, thank you

I did sync my date and time already.

The not joys of farming…
Thought I’d be all set, moved all drives, mounted on fresh chia install on fast pc blue screen hit and corrupted my d/b.
Now copying one across and praying it works.

Sorry to hear that,I hope there will be a better way in the future with db issue.

Well, ive fixed mine already!
Mine wouldn’t get past loading screen before you even select keys.
Hopefully will work for you to.

Stop chia if it’s running.
Backup your big database folder somewhere.
Delete all chia folders.
Uninstall chia.
Re install chia.
Start chia. ( my keys were still stored, so clearly uninstall doesn’t actually remove folders ).
Skip the next page where you can drag n drop.
Start chia.
Once its fully open and you’ve selected keys and loaded, Stop chia.
Delete new database ( just the 1 file, file not folder.)
Put your good database in folder.
Restart chia.

I know you tried this, but had you unstalled chia?

If it doesn’t work, I’ll gladly try and upload my dB somewhere for you, I know ppl shouldn’t do that you’d need to trust me.
I can only say, I can’t code and wouldn’t have the slightest clue how to do anything malicious.
But it is a risk, but the offers there.

How did you fix a BSOD doing what you say? BSOD is a Windows/PC Hardware issue, not a chia issue.

I reset the pc lol, same way i always fix em.
I’ve yet to have a bsod that has not fixed.

I was talking about fixing chia not loading.

Oh, that’s not what you said. BSODs are not fixed by simply ‘resetting’ the PC. There is always a deeper reason to be determined so it does not reoccur.

I dunno, screen was blue, showed a qr code to chase the fault,

Hit reset and I’m good.
Happened a few times when i was running mad max.
I always assumes that was a bsod, it’s the only error ive seen in 30 years of using win, but they never used to have the qr code.
Iirc they also weren’t always blue.

Maybe catch up with this>

“When a BSOD error arises, open QR Code Reader on the Android mobile. Then point the phone’s back camera at the QR code. Center the QR code in the middle of the screen so that it fits within the square’s four corners. The mobile will then scan the code.”

# Windows 10 blue screen of death? Now Microsoft adds QR codes to BSOD crash support < April 12, 2016

Thanks, but honestly, in 30 + years a reset has ALWAYS worked for me.
Maybe I’m just lucky.
I dont explore problems till I have to.

As a (retired) PC Tech, that was my job (exploring problems). Clients didn’t like repeats, esp. BSODs :laughing: