Problem when I connect many disks to the farm

Hello, how are you all? I have a query to this community after searching, previously everywhere on the internet.

First of all, I apologize for two things: 1) My horrible English, 2) If it is not the right place to ask.

Product Name: B450M AORUS ELITE (1.x)
BIOS Ver: F63d
CPU: Athlon 3000G
Operating System: other - Linux Mint
SP: Mate
Brand: other - GeiL
Size: 16gb
Power Supply: 850w
Memory Part No.: GAOR48GB3000C16ASC

I have a hard disk system, with the configuration described in the subject. It turns out that I have 36 physical drives attached (One SSD for the operating system and 35 large storage hard drives). For this I use 3 PCI-E adapter boards with 16 sata ports each, since natively the motherboard only has 6 native ports. Now the issue comes when I install disk number 37 by connecting it correctly, the PC does not start, that is, it does not get to boot. In the first place, I thought it was a power problem due to the Spin Up phenomenon that is generated with the disks when the computer is turned on, so I installed an additional source. It turned out that even the error persisted. Then I thought it was the RAM so I added 16gb of RAM and the same problem happened. Later I thought the problem was with the 16 port PCIE adapter boards and swapped them for others, but the problem persisted. Finally, I came to the conclusion that the problem may come from the processor or the chipset of the motherboard (they do not support more than 36 physical units at the time of launching the operating system). I would like to have your help to solve the problem. Obviously attached pictures of everything. Something interesting to note is that after leaving 36 physical drives, finish starting the operating system and make it stable, I take the time to connect disk by disk (of those that were left without connecting) and the operating system reads them correctly and can be used correctly (I have more than 70 disks to install). This, although it may be good momentarily, it is problematic for me when it comes to restarting, shutting down or having to do something that requires restarting the order since then the computer does not boot correctly.

I really need your help. Thanks a lot. The PCI-E expansion or adapter boards to 16 sata ports that I use are the following (they work perfectly).

I’m sure of something: The problem comes from the motherboard or the processor. Today I did new tests and it supports up to disk number 39. After I install disk number 40 in the rig the pc does not recognize it and I have to disconnect and connect it manually so that it appears in the disk manager.

I’m not familiar with this motherboard but does this code appear when you power on the PC and you are not able to get in to BIOS with 37 HDDs connected? If so, can you get it to BIOS with 1 less drive and does BIOS see all the disk when you go in to bios one time boot or boot options? If so l the BIOS may be setup to allow boot from add on cards which should be disabled as likely the BIOS has a limit how many drives it t can enumerate.

If you can get in to BIOS with 37 disks but the issue occurs during OS boot then the issue may be on the Linux kernel side.

1 Like

This looks like a power problem. What cables are you using to connect the disks? Shouldn’t you connect more than 6 disks to a single psu output. Cables can’t handle it.

1 Like

Power problem. Must get second psu. Also do not use spliters to add more than 8 per cabke to psu. I would recommend you get a hdd server and go that route. 36 bay runs around 800 to 900 or around 1200 with all hardware and mb included. It’s a better way and saves on energy.

No. The problem comes from Bios. I can’t do anything at all directly. As indicated in the text, if I leave 36 disks, I start Linux and then connect the other hard disks outside (Hot Plug).

I use cable splitters x 5 sata power. The issue is not one of power because I have three 850w sources connected to test (a total exaggeration) on purpose and the problem does not come from the power sources.

As indicated above I am now using 3 850w sources and the error persists. I firmly believe that it has to do with the B450 chipset that does not support more than 37 physical disks connected at startup.

Possibly a hardware limitation in trying to assign IRQ or other resources to meet the demands of the SATA cards/drives ?

Once in a modern OS, this can be overcome at the driver level, but in a (potentially limited) BIOS this could be an issue.

I would turn off every device in the BIOS that you are not using - sound card, onboard network card, onboard video card, onboard serial ports, onboard USB controllers etc etc (only if you are not using them or they are less important to you than the 38th disk…).

This might be enough to coaz the system to recognise the disk and a few more on top of that - but it will run into a limit at some point…

1 Like

Very interesting what you say since I had thought about it from the beginning. The idea of ​​this request for help is to set a precedent, since honestly, if you look for information on the web you will not find anything, or at least I could not find anything that speaks of a physical limitation of disks on a conventional motherboard / gamer .

I’m going to try to turn everything off to verify. The last option I have is to try the microprocessor (since being a G series it may also be making everything difficult).

Sorry I missed the part of psu. Make sure bios is up to date not only on mb but also on sata expansion cards.

1 Like

Nothing happens friend, everything is fine!
If everything is updated to the top.
Capable of switching platforms to Intel to give me a break through the PCI lanes.

I have a system similar to yours. 20x sata and 43x usb disk are connected. No problem. I still think you have a power problem. You should check if there is a cable whose temperature is increasing.

Gigabyte b450m s2h+Ryzen 2200g+16GB 3200mhz ram+sx8100 500GB+7 port usb PCIe+20 port sata PCIe card (No VGA)

But man … your configuration is totally different. If I connect via USB from disk 37, it detects it and the pc can safely boot. The issue is when you connect from disk number 37 by SATA interface.

You didn’t say how big the power supply is?

Yes, I mentioned it in the answers. Install, over the top, three 850w sources to see if the problem was electrical.

Yes way up at the top sorry I started half way through

The PCI sata card you are using already has a sata controller. I don’t think it’s a motherboard problem. Maybe the sata card is faulty.

Additionally, home user PSUs are fine on the 12 volt channel. But on the 5 volt channel it is very bad.

Have you looked at and tried to see if PUIS is supported on your motherboard/BIOS/disk setup ?

This is what hdparm manual says:

Enable/disable the power-on in standby feature, if supported by the drive. VERY DANGEROUS. Do not use unless you are absolutely certain that both the system BIOS (or firmware) and the operating system kernel (Linux >= 2.6.22) support probing for drives that use this feature. When enabled, the drive is powered-up in the standby mode to allow the controller to sequence the spin-up of devices, reducing the instantaneous current draw burden when many drives share a power supply. Primarily for use in large RAID setups. This feature is usually disabled and the drive is powered-up in the active mode (see -C above). Note that a drive may also allow enabling this feature by a jumper. Some SATA drives support the control of this feature by pin 11 of the SATA power connector. In these cases, this command may be unsupported or may have no effect.

If there is a power problem (which is possible but personally I don’t think there is…) it would help prevent the higher current draw on startup by not spinning all drives up at one time. Much like larger RAID controllers do in enterprise setups.

Sure, but let’s go again. I already made it clear that I configure three 850w sources, doesn’t that seem like too much for 37 hard drives? On the other hand, I tried other sata pci cards and it also gave me the same error and on another motherboard (with the same b450 chipset and the same ATHLON 3000G cpu).

Currently I completely deactivated the HDPHARM PIUS to test if that was the problem and it is still the same. Conclusion. If you have a b450 or athlon 3000g chipset for a farm, you shouldn’t install more than 37 disks via sata. Hopefully this can set a precedent for the community.