Wallet address changes and cant see change payout address option in pool tab

I saw that several times when I’ve restarted chia gui 1.3.3 my wallet address changed.
I even deleted the wallet so it can be created anew and it still happening.
I’ve changed the address via the button and looking to see if it sticks.
Also no option to change payout address in pool tab’ So I’ve entered it in the config.yaml and it changed.
Any ideas whats wrong ?
Thank you

Just stop.
No offenses
Your not sure what your doing my friend.
Very likely you will screw something up.

Everything is fine. Just undo everything u have done. As long as u entered ur seed on a fresh install of chia. Ur just fine.

Don’t edit ur config.yaml unless u have harvesters.
Ur wallet db u delegates has nothing to do with ur wallet in the gui.
Don’t worry about all your wallet addresses

It’s real simple. If u troubleshoot that wich is not broken. U will surely break it. Especially if u have a loose understanding of how it works.

Leme know if that helps.

At ur point. Me. Id tear down the node. Start fresh. New windows install. Only install chia… and put in that 24 seed. And just be patient. Attach plots.
Than watch the money roll in

1 Like

Did you upgrade from 1.2.11 to 1.3.3? If so you need to run the .\chia db upgrade If you install fresh it will create the v2 data base while it sync’s

Just asking

@ drhicom - I’ve installed 1.3.3 from fresh with entering the 24 words key and then closing it, Copying the V1 database and then upgrading the database to V2.
The thing with the wallet change has happend in every 1.3.X version once, But this time the address changed FEW times upon restarting the chia gui.
@ jones - It’ll take AT LEAST few days to rebuild the V2 db from scratch, And I keep it as last option. I’m using chia gui for almost a year and I KNOW what I’m doing. The 1.3.X contain some major bugs which I haven’t experienced in previous versions.

I haven’t installed 1.3.3 from scratch only upgrades. If you run the 1.3.3 from scratch it should create the v2 and start syncing. Also the config.yaml wallet db still says v1, but was told in keybase that the software points to v2 wallet go figure. I may install the latest beta in a windows VM and see what happens.

I made the jump to 1.3.3 on my windows 1l physical machine… my wallet only it had no trouble

… as for my farmer windows 10 vm ive also upgraded it to 1.3.2.
shortly after all my plots forgot that they where part nft plots. and lost all my nfts… and my chia…
everything started to break…
so I deleted my wallet db. and upgraded to 1.3.3 … … .

and mannnn 1.3.3 is a milestone

super all buttery now with only the new db…
it was worth the re sync for SURE
everything back up healthy and 0 syncing issues

ubuntu harvesters are latest as well. no trouble there.

literally the new wallet db took 3 days tops over gigabit ethernet. no sweets… don’t try lugging around a obsolete database… make the jump brother

1 Like

Ok. I accept your viewpoint. Seems to me that starting completely fresh will prob those basic problems I’ve encountered on v 1.3.x.
I’ve started the process and hopefully it’ll be done in few days time.

Thank you

1 Like

Don’t forget to keep some water around,


I don’t think that is true. On my test box, first I did an update, and upgraded db to v2 (so config.yaml got changed). Then I killed that db, and let it sync from scratch. The new db name had v2; however, the POS ended producing v1 db (still ended up with 100 GB). Although, that was on v1.3.1. Maybe that got changed on v1.3.3 (doubt it, as the only change should be the OpenSSL fix).

So, the best way to proceed with a new setup is to start it, let it run for a couple of minutes (to start syncing / generating a tiny db), stop it, run the upgrade (will take a couple of minutes), and only then you will end up with bc v2 db.

I guess, that speaks volumes about Chia confidence in the new db (for me).

could be. who knows what kinda wizardry the folks at Hogwarts chia school are throughing in when no ones looking tho. but sssl could affect db tho… it affects many many things. people are really attached to their .db’s its kinda icky

I think the new db is like upgrading ur turbo on ur dodge neon. and adding a better blow off…

I don’t see much if any improvement as far as blockchain db. Sync times are about the same, start_full_node processing sucks as before. It looks to me that the only change is removing junk from db, and all “improvements” are only due to a smaller footprint (OS does better caching).

Although, wallet db change is super. The size dropped by THREE magnitudes. Just think how much garbage the original wallet had in order to pull such big change. Incompetence at the highest level.

I think they just went with what they knew worked and people wanted things to happen immediately. so they gave an immediate solution. us a outdated db structure… till it just starts to crumble… than replace it… what they didn’t account for is how much affect it would have on the client system as a whole.

Just to get back with you, I installed chia 1.3.2159 latest beta added my 24 words and it created the v2 db and started syncing. The wallet came up quick, I stopped it and deleted the node db v2 and copied one from a backup two days ago.

How do you know that it was actually v2 structure, not just v2 name? I ended up waiting 30 hours to see that 90 GB. The name was also v2.

I guess, knowing that there may be potential issues, we could use sqlite3 utility to compare tables, that would be the fastest check. I wish the UI would show which bc version it is, and suggest a switch to v2.

I let the new install sync for 10 minutes the shut it down, deleted the files in the folder and copied a v2 database from another machine’s (v2) db that a backup was made a couple of days ago. Right now I’m upto April 15, 5:17am. So I’m a couple hours behind on this test VM machine, not too bad, it’s now at 60k

1 Like

Almost there, this is what the beta 1.3.2159 looks like.

Always testing…

You’ve been about for ages, you know what your doing, so if these questions sound daft forgive me ,I’m only trying to help.

Do you mean the receive address in the wallet tab?

If so, that’s completely normal, it changes every time you send a transaction, or install, because you should never re use addresses in crypto . Ppl do, but you shouldn’t.

You alter the addresses you want to recieve coin to under your farm tab , 3 little dots on top right, one is for the .25 reward, the other us for your 1.75 on your OG plots.

I change my pool payout address for pool payouts at the pool, not in the pool tab as you seem to be trying to do.

Not sure which pool your with or how yours works , but thats how space pool works.

There are 3 little dots on the nft, you can change a payout address there, but i believe that is set to the pools wallet, so they can claim the 1.75 and split it between poolers.
I also can’t change this, I just tried.
If you went solo, I believe you could then alter it to any address you like.


On my test machine, I just upgraded from v1.3.1 to v1.3.3. It already had v2 db fully synced, but I removed everything from blockchain db folder, but left config.yaml with v2 name (left the original config.yaml intact).

After chia started syncing (i.e., bc db was produced), I stopped it and run the following command:

your_drive_and_path\sqlite3 -readonly blockchain_v2_mainnet.sqlite "select * from database_version"

The responses was:

Error: no such table: database_version 

This indicates that this db is v1, even though the name implies v2 (I wrote about this nonsense in another thread already).

Running the same command on v2 structured db produces a single digit output of “2”.

Also, just to make sure, I checked tables in this db, and those are the same as in v1.

So, maybe when you really start clean, and there is nothing on such drive, chia will start with v2 db, but I really doubt it.

  1. I meant that the recieve address was chaging several times after few restarts of the GUI without any transaction made

  2. i am self pooling for few months now, And since 1.3.X, it changes self-pooling to spacepool pooling and I need to change it manually to self pooling, Which wasn’t always successful (For example stuck few hours on “Pending” mode).

I created fresh install of 1.3.3 without importing old DB and now waiting for it to sync (It shows now self-pooling correctly, And the recieve address and pool payment address is the same BUT I still don’t see the option that was before in the pool tab to change payment instructions. I only see add a plot and delete unconfirmed transactions)