Why there are still major bugs in CHIA Gui 1.3.x?

I was patient and tried every version of CHIA Gui 1.3.X, And every time I’ve tried to upgrade from 1.2.11, I’ve encountered different problem.

First, There was the change of wallet address and I wasn’t able to change the payment instructions, Even through the puzzle hash calculations and config, So I went back to 1.2.11.

Then there was no sync and the creation of V2 DB which just did nothing and did not allow me to continue syncing, So I’ve removed the .chia folder, Did a fresh install with entering the 24 words key, Then moved the .chia folder back - To find out it started syncing from 0 and ignoring the DB… - So I went back to 1.2.11.

There goes 3 seeding days to waste…

Why the developers can’t get this 1.3.X right for MONTHS now ? I will wait for few months until and IF they’ll get it right

1 Like

You are joking, right?

I don’t think that there was a clean / stable release yet. v1.3.2 had one change, and one change only (link an updated OpenSSL lib), and that was butchered (no QA whatsoever). We upgrade, ask question on the forum is something goes South, and hope for the best.

One of the main reasons to go for v1.3.x is that v1 blockchain db grows right now by ~30 TB/month…

1 Like

Don’t think it is that high! :wink:

1 Like

I prefer to have a stable 1.2.11 than to waste DAYS in order to get the 1.3.x synced, Although the benefit of smaller db is quite important to many people.Right now this upgrade Is a huge waste of time in my opinion due to it’s MAJOR bugs.
There were minor issues with pre 1.3.X versions of chia that was worth investing the time to upgrade to, But this release is really sub-par and shouldn’t be realeased until it is much better “cooked”.

It is. It started to be that high when this ongoing dust storm started in early Feb. I wrote about it on the forum, as it was bugging me a bit.


Hey, I am not arguing with you. I was sitting on v1.7 for very long time. When I tried to upgrade to v1.2.11, I also wasted plenty of time (there was a bug logged on github that those older versions didn’t want to upgrade directly to v1.2.11). It is just how Chia operates, we are the QA, and after investing ~$500m (just in HDs), we need to put up with this crap.

Those v.1.3.x are just samo-samo, but there are some good changes, and really no hope that any next update will be any smoother.

Just search the forum for how people upgraded, what is recommended, and go for it. If something will go bad, just ask.


I upgraded pretty much every version within a month of release and have never spent more than 5 minutes on it.

Never had any problem more serious than needing to restart.

The only one i skipped was the first 1.3 release.


Just did mine to 1.3.3
Went smooth, ran upgrade while farming on main node.
Took under 7 hrs on an old 8350 box . ( not sure of exact time, was just done when I woke)
Need to sync the last 7 hrs, but its doing it.
10 mins to catch up sync and I’m farming again.
Just my experience.

I’ve had no issues with it not closing down correctly to corrupt db , nft’s are always present and not vanishing anymore.

I’m happy.


Glad to hear you had positive experiences. I’m waiting for few more versions down the line in hope that the transition will run more smoothly.

1 Like

I upgrade every time there is a new version out.

I have had one issue : farming reward addresses disappearing in GUI in 1.3.0, checked config.yaml and all was good so was UI error.

Everything else worked as it should and the upgrades are very quick.


To clarify, I just meant to say that something not working smoothly is not always a sign of bad software or lack of QA. With so many different OS, OS versions and hardware/software combinations there is always going to be a percentage of people who will experience problems due to some unforeseen combination of things.
People who don’t have trouble normally also don’t talk about it, only those who do have trouble.

To judge the software as a whole you need to know the percentage of people who have problems.
That’s my opinion anyway.


To keep things in perspective, our beloved :yum: (to some - just kidding) Windows 10 was released July 29, 2015… yet yesterday, after yet two thousand, four hundred, fifty one days (2451) … I commented to my wife that this Update Tuesday this month brought… :face_with_monocle:

### What to Know

* The latest Patch Tuesday was on April 12, 2022, and the next one will be on May 10, 2022.
* It fixed **119 security vulnerabilities** across Windows operating systems and some other Microsoft software.
* **10 of the updates were marked as *Critical.***

Here’s a summary list > Patch Tuesday (Most Recent: April 12, 2022).

So only my opinion, but I believe Chia dev are working every day to make this effort stronger, better, but they are still human, make mistakes, and/or can’t foresee every possible eventuality and hardware glitch that will occur across the spectrum and variety of nodes. Just saying.

As someone involved in the IT industry for the last 34 years, might as well get used to software bugs and upgrades, because typically they are better, at least after a fashion.

So hang in there!! :rofl:


In my opinion all versions are littered with bugs, some simple which could be easily fixed, for instance make a mistake in the config file and it just falls over with a spinning disk, what ever happened to catching errors.

I’ve no idea what uninstalling does, as it seems to leave everything behind.

1.3.3 just randomly stops farming, no idea why, close it, make sure it’s really closed and restart it and it works again.

I had that on .2.11 , PITA, not much to do about it other than wait on a fix though…

The problem I have, and not sure if this applies to all versions or just 1.3.x, is that if the Chia GUI closes unexpectedly (power outage etc.), then I get issues with the Wallet Database.
The Full Node syncs fairly quickly, but the Wallet Database seems to freeze. If you close and restart the Chia GUIA again, the Wallet eventually syncs but you find that you have about a months worth of transactions missing.
So I have to close the GUI, delete the Wallet Database and recreate it from scratch which takes about 12 hours.
My Wallet is using the V2 database.
I’m sure this database could be made more resilient for this type of event.

It’s new, give it time.

Have to say I have had no major issues recently, I always updated within hours of a release.

My biggest issue was the dB upgrade, which took ages on my pi .

So I actually did the upgrade on windows and copied the upgraded dB to the pi

1 Like

I second this. I skipped 1.3 and was actually surprised how smooth the 1.3.1 upgrade was considering all of the complaints. I ran through the standard upgrade process, ran the ‘db upgrade’ command after I was already farming on V1, then switched, restarted the farmer, and boom, farming again.

I’ll have better real world data in 4 hrs , I’ll update, but looks like the upgrade has turned my old box from a slow poor performer with late responses into a capable node.
But maybe it’s also having 40 peers rather than 80.

1 Like

Are you running windows or linux? Hows the space on your boot disk etc? CPU and memory?